Release Updated Powder, Can't Upload to Repo

Discussion in 'Software Releases' started by Thann, Aug 27, 2011.

  1. Thann

    Thann Still Fresh

    Joined:
    May 28, 2010
    Messages:
    26
    Location:
    Santa Barbara, California
    Because I'm not the original packager! anyway if you guys want it here it is. If you guys can get it uploaded, or know how I can (I already contacted joseluis) go for it/ tell me.


    It's a great game, thanks to everyone who made it happen!


    Powder 115 PND
     
    Last edited by a moderator: Aug 28, 2011
    Tags:
  2. Link

    Link ithic.com

    Joined:
    Aug 27, 2010
    Messages:
    2,937
    Location:
    Vermont
    Thank you, great way to sit through a hurricane. Let me try this out!
     
  3. foxblock

    foxblock Asleep

    Joined:
    Jun 17, 2009
    Messages:
    1,365
    Location:
    Germany
    Hi there,


    sorry kinda missed this, but I got your report now.


    To add you as maintainer I need the username you use to login on the repo, I assume it's "Thann", but I would need your confirmation to be sure.


    (Reply to me here or to the mail I sent you).
     
  4. milkshake

    milkshake Advanced Member

    Joined:
    May 18, 2009
    Messages:
    3,735
    Location:
    Rotherham, UK
    As per my pm I forwarded your report on to the original uploaded I would have hoped he would reply to ur report as it contains your email if not my suggestion would be just to upload your own version


    I.e. use your own package id, there would be 2 available versions, you could just add some information about ur updated version to the additional info.


    I'm not too sure adding maintainers to someone else's upload without their prior consent is the best idea what do u think foxblock?
     
  5. foxblock

    foxblock Asleep

    Joined:
    Jun 17, 2009
    Messages:
    1,365
    Location:
    Germany
    I agree that messing with someone else's upload should be avoided, but I don't like the idea of having multiple PNDs of the same app, especially if those are about version differences (and the changed have been confirmed working) and not major structural changes - it's confusing and enforces the problem the repo actually should be solving.


    In this case as you forwarded the report and this notice has been in here for quite a while it can be assumed that the original author is probably MIA as he would have responded otherwise.


    Also the original version is not lost, it's still available from the older version archive.
     
  6. milkshake

    milkshake Advanced Member

    Joined:
    May 18, 2009
    Messages:
    3,735
    Location:
    Rotherham, UK
    fair enough, looks like its already been solved anyway :p
     
    Last edited by a moderator: Sep 11, 2011
  7. skeezix

    skeezix Internal Development

    Joined:
    Mar 11, 2003
    Messages:
    8,060
    I hope this fixes the broken run.. The old Powder exitted immediately after launchin a bg app.. So pnd tried to exit and half blew up while game went on. Sortof worked in xfce but bi flop in mmenu


    Bad port :)


    Jeffphone
     
  8. Thann

    Thann Still Fresh

    Joined:
    May 28, 2010
    Messages:
    26
    Location:
    Santa Barbara, California
    The odd problem of Powder exiting when using mini menu is still there unfortunately.


    But thanks guys for helping me resolve this issue!
     
  9. skeezix

    skeezix Internal Development

    Joined:
    Mar 11, 2003
    Messages:
    8,060
    Thann .. any chance you'll look into fixing the launch behaviour? Its really not good the way it is, if it still has the fork/unmount problem :) (it .. causes some instability/leaks afterwards with the improper unmount, doesn't work for minimenu users at all, etc.)


    Perhaps the run-script has an extraneous & to cause backgrounding when it shouldn't (5 minute fix), or perhaps the code does a fork() and exit on parent, or something; in that case, coudl fix the code.. or even easier -- just have the run-script do a loop, using ps | grep powder to see if its still running and if so, repeat; exit the loop when the program is not found, letting the run-script exit and return to pnd_run.sh to do the unmount stuff. (20 min fix :)


    Should be an easy fix...


    jeff
     
  10. Thann

    Thann Still Fresh

    Joined:
    May 28, 2010
    Messages:
    26
    Location:
    Santa Barbara, California
    Haha, the hardest part about fixing that was to stop playing powder long enough to upload it to the repo!


    You were correct, It was launching in the background.


    Let me know if I can improve other programs or packages, I don't know of any "help wanted" section other than port requests.


    Thanks for Everything PortMaster Skeezix!
     
  11. skeezix

    skeezix Internal Development

    Joined:
    Mar 11, 2003
    Messages:
    8,060
    Thanks for fixing it :) I'm a roguelikes fan :)


    jeff
     
  12. sebt3

    sebt3 homebrew player (P. & C.)

    Joined:
    Sep 9, 2008
    Messages:
    4,747
    Location:
    France
    Fix the issues you have in the app/games you use. Port those you want to use... good enough for me ;)
     
  13. kuru

    kuru Laptop und Trachtenjanker

    Joined:
    Jan 13, 2009
    Messages:
    1,770
    Location:
    the mockracy
    After lying dormant for about a year I pulled out my Pandora again...

    Does this game work for anybody? PND won't start on my CC, powder.sh not found. I tried compiling from source but I'm bad at this. This is like the only game I really wanna play next to gravity something. And Powder is pretty bad on a touchscreen-only thingy.

    In other news, youtube downloader doesn't download anything :-(
     
  14. levi

    levi Still fresh, damnit!

    Joined:
    Oct 6, 2008
    Messages:
    11,105
    Location:
    Somewhere off the coast of the EU
    The version from the repo (that you commented on) works for me on my Ghz.

    The log isn't very long, but it is powder.sh that starts.  That just reports 'Powder initializing' and that's it.  Perhaps you've a corrupted download?
     
  15. kuru

    kuru Laptop und Trachtenjanker

    Joined:
    Jan 13, 2009
    Messages:
    1,770
    Location:
    the mockracy
    Hm, I deleted and reinstalled it at least half a dozen times until giving up :-s

    Well now I have an incentive to keep trying - took long enough for someone to try on their unit. Thanks Levi.
     
  16. levi

    levi Still fresh, damnit!

    Joined:
    Oct 6, 2008
    Messages:
    11,105
    Location:
    Somewhere off the coast of the EU
    FWIW, the last few digits of the MD5sum of my PND are ...6f9600b0. You should be able to verify whether your copy is the same as mine with that.
     
  17. kuru

    kuru Laptop und Trachtenjanker

    Joined:
    Jan 13, 2009
    Messages:
    1,770
    Location:
    the mockracy
    So I've got my Pandora back and the md5 I get is

    7373ba5c5ceb3d4bec5ae765bf9600b0

    for powder.joseluisjazz.pnd. Same result on other PCs.

    Edit: Manuelly mounting the PND, check contents of UTMP directoy... just a bunch of character text files from guys I have never created, a savefile and a readme.

    Could somebody please, please upload their working PND somewhere? I need perfect Powder on Pandora, pretty please :(

    Editedit: Looking at the PND in PNDtools, looks fine, powder.sh is there.

    Edit³: Nevermind. Got the binary from PNDtools, copy to opa, create starter.

    Still wondering what's wrong with the PND though.
     
    Last edited by a moderator: Dec 22, 2014
  18. NearTao

    NearTao Member

    Joined:
    Sep 13, 2008
    Messages:
    370
    do you have two copies of powder installed in different directories or SD Memory cards?
     
  19. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,209
    Location:
    Innsmouth, MA
    Hi all !

    Sorry again for resurecting an old thread :p

    @joseluisjazz and @Thann : Could Powder be updated to 118 beta 3 please ?

    Cheers, Magic Sam
     
  20. Magic Sam

    Magic Sam Forever Homebrew

    Joined:
    Aug 10, 2007
    Messages:
    2,209
    Location:
    Innsmouth, MA
    Farox likes this.

Share This Page

Loading...