GP2X Setting Up Visual C++ 2005 Express With Gp2x


hitbyambulance

Active Member
Joined
Nov 26, 2005
Messages
635
Location
Seattle, WA
Website
troubletype.org
ok, i've been following the instructions in the wiki here. i am also using Demo.c as on this page. now, i believe i have followed all the set-up instructions - except for this second to last step:

Make your First Build

1. Create a new text file with the extension .link to the project. This is to trigger the arm-linux-link build rule.

umm, what does this mean? create a blank textfile with the extension .link and put it... where? or what?

so i made a blank textfile with .link extension and put it in my projects directory. when i try to compile i get:

1>------ Build started: Project: GP2Xtest2, Configuration: Debug Win32 ------
1>demo.c
1>Project : error PRJ0002 : Error result 255 returned from 'C:\WINDOWS\system32\cmd.exe'.
1>Build log was saved at "file://c:\Documents and Settings\dustinb\My Documents\Visual Studio 2005\Projects\GP2Xtest2\Debug\BuildLog.htm"
1>GP2Xtest2 - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========


and here are the contents of BuildLog.htm:

Build Log


Build started: Project: GP2Xtest2, Configuration: Debug|Win32


Command Lines

Creating temporary file "c:\Documents and Settings\dustinb\My Documents\Visual Studio 2005\Projects\GP2Xtest2\Debug\BAT0000025123456.bat" with contents
[
@echo off

arm-linux-gcc.exe -c -IC:\devkitpro\devkitGP2X\include\SDL\ -o Debug\demo.o ".\demo.c" 2>&1 | sed -e s/(.[a-zA-Z]\+):([0-9]\+):/\1(\2):/

if errorlevel 1 goto VCReportError

goto VCEnd

:VCReportError

echo Project : error PRJ0019: A tool returned an error code from "demo.c"

exit 1

:VCEnd
]
Creating command line """c:\Documents and Settings\dustinb\My Documents\Visual Studio 2005\Projects\GP2Xtest2\Debug\BAT0000025123456.bat"""

Output Window

demo.c
Project : error PRJ0002 : Error result 255 returned from 'C:\WINDOWS\system32\cmd.exe'.

Results

Build log was saved at "file://c:\Documents and Settings\dustinb\My Documents\Visual Studio 2005\Projects\GP2Xtest2\Debug\BuildLog.htm"
GP2Xtest2 - 1 error(s), 0 warning(s)

what am i doing wrong?
 
Last edited by a moderator:

refractor

Still Fresh
Joined
Jun 15, 2006
Messages
72
Location
Luxembourg
Website
Visit site
hitbyambulance posted on Jul 22 2006 at 02:54 AM said:
Make your First Build

1. Create a new text file with the extension .link to the project. This is to trigger the arm-linux-link build rule.

umm, what does this mean? create a blank textfile with the extension .link and put it... where? or what?

Add it to the project in Visual Studio. Yes, it's just an empty file. The "text file" is slightly misleading, I think, because of course you just need an empty file with a .link extension.

hitbyambulance posted on Jul 22 2006 at 02:54 AM said:
what am i doing wrong?

It's hard to tell without more info. Run the command below (from the generated BAT file) from the "c:\Documents and Settings\dustinb\My Documents\Visual Studio 2005\Projects\GP2Xtest2" directory and see what you get.

arm-linux-gcc.exe -c -IC:\devkitpro\devkitGP2X\include\SDL\ -o Debug\demo.o ".\demo.c" 2>&1 | sed -e s/(.[a-zA-Z]\+):([0-9]\+):/\1(\2):/

That should give you a clearer error than the one VS is giving you.
 
Last edited by a moderator:

slygamer

Member
Joined
Sep 19, 2005
Messages
795
Location
Brisbane, Australia
Website
Visit site
Try running arm-linux-gcc.exe by itself from a Command Prompt. It might not be able to find arm-linux-gcc.exe, in which case you have not got c:\devkitpro\devkitgp2x\bin in your PATH.
 
Top