1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Problem with Linphone (Split from other topic)

Discussion in 'Support Area' started by sukhi2011, Sep 24, 2011.

  1. sukhi2011

    sukhi2011 Member

    Joined:
    Apr 26, 2011
    Messages:
    845
    Location:
    Birmingham
    I'm trying to use linphone but when i type my own landline no. it just says call ended,why isn't calling the no. i'm dialing.
     
  2. Prometheus

    Prometheus Well-Known Member

    Joined:
    Mar 8, 2008
    Messages:
    9,474
    I've split this from the Pandora General topic about whether Skype is available on the Pandora, and moved it to the Support section. I believe the question will get the attention required here.
     
    Last edited by a moderator: Sep 24, 2011
  3. MarioPandio

    MarioPandio Well-Known Member

    Joined:
    Aug 28, 2010
    Messages:
    1,378
    Location:
    Half way up the stair
    Hi sukhiextreme,


    Your unlikely to get too far with Linphone at present I'm afraid to say. Consider it more a proof of future concept at this stage. Both Ekiga (crashes) and Linphone (has ALSA and MIC and Bluetooth issues) need further work before they will offer VoIP via SIP protocols/accounts.


    Linphone requires also that you have enabled the internal MIC of the Pandora (which I know from prior posts of yours that you HAVE done so for use in Audacious), and it has been shown by mcobit to work with webcams to display picture, even though Sebt3 built his Linphone port with Webcam support supposedly disabled. However no-one has managed more than a test call to themselves (Alerino) or to anything beyond a test-call echo room service, in which they can hear the audio coming to them but without the MIC enabled cannot speak back.


    I think in both cases of Ekiga and Linphone, better results were had in Debian extends, or perhaps Pandebian, than in the XFCE default OS.


    In XFCE we have to wait aswell for the next OS release Yars, in which better Bluetooth handling is intended to be included, as currently you cannot have more than one audio stream using BT, unless you make a modification to the .asoundrc file hidden in your home directory, as discovered by Custom Processing Ultimate here http://www.gp32x.de...post__p__947023 which is part of the actual thread about the port of Linphone when it was released by Sebt3.


    These other threads all mention Linphone or Ekiga but all ultimately lead to the conclusion that we dont have a fully working VoIP solution on the Pandora yet, so you will have to wait or figure it out yourself somehow (which doesn't mean being told to OC to 1337mhz either ;) )


    Linphone thread


    http://www.gp32x.de...58289-linphone/


    Ekiga


    http://www.gp32x.de...ic/57263-ekiga/


    Voice Chatting


    http://boards.openpa...__fromsearch__1


    iPhone 4 vs Pandora


    http://boards.openpa...__fromsearch__1


    VoIP


    http://boards.openpa...__fromsearch__1


    Feature requests for HF6


    http://boards.openpa...__fromsearch__1


    Skype on Pandora


    http://boards.openpa...__fromsearch__1


    best of luck :)
     
    Last edited by a moderator: Feb 6, 2016
  4. mcobit

    mcobit Advanced Member

    Joined:
    Jul 28, 2008
    Messages:
    6,755
    Great explanation!


    Now we have something to copy&paste into every now topic about voip. :)
     
  5. sukhi2011

    sukhi2011 Member

    Joined:
    Apr 26, 2011
    Messages:
    845
    Location:
    Birmingham
    It's asking for sip address or phone no. what do you write their,well i typed in a no. which was my own,it doesn't go through,why is that happening,threads don't explain that,when you dial a no. it just says call ended,when i press green button.
     
  6. alerino

    alerino Well-Known Member

    Joined:
    Aug 11, 2007
    Messages:
    3,199
    do you know anything about sip?


    please don't tell me you thought you could just run the app and dial numbers?
     
  7. vandyswa

    vandyswa Member

    Joined:
    Sep 15, 2012
    Messages:
    107
    Location:
    Seattle, WA
    FWIW, this is my current project. The Pandora's audio setup is with a (play only) dmix on top of hw:0,0 and then the


    microphone(s) (built-in and via speaker jack) on hw:0,1. Linphone seems befuddled by this, not fatally, but things just aren't lining up perfectly. I've just enhanced the "alsadev" config parameter so Linphone can know about two distinct ALSA devices. I'm hoping that can simplify some ALSA variables and let me get true calling working, after which I can circle back and get the audio output to go via dmix while still getting microphone input from hw:0,1.
     
  8. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,232
    I'm interested in this, can you tell me what you've done plz ?
     
  9. vandyswa

    vandyswa Member

    Joined:
    Sep 15, 2012
    Messages:
    107
    Location:
    Seattle, WA
    linphone doesn't let you specify more than one hardware ALSA device. So for that config entry I burst "dev1|dev2|..." and create dev1, dev2, .... This lets me have an explicit hw:0,0 for audio and ring, and hw:0,1 for the microphone. It still doesn't work, and hell if I could make its debugging system work, so I just put fprintf(stderr, ...)'s into the code. It looks like the number of channels parameter for the capture is what's bombing. I'll keep you posted.
     
  10. vandyswa

    vandyswa Member

    Joined:
    Sep 15, 2012
    Messages:
    107
    Location:
    Seattle, WA
    Yes, looks like the capture device, hw:0,1 will not accept # of channels==1. That's pretty weird, seeing as it's not a stereo microphone. I guess there's some confusion, because it looks like the internal microphone is assigned to left and the one on the headphone plug is right (or vice versa, but you get the idea). I'm going to tweak linphone to look at the HW channels via ALSA and adjust its idea of # channels. But this unusual style of capture hardware (as represented in ALSA) is probably not going to play well with most Linux programs....
     
  11. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,232
    Ok thanks.


    One thing: i installed Linphone under Slackware, but didn't have this problem, config went fine.


    I can phone a call, but big problem: i hear nothing, and neither the ppl i call :/.


    Ekiga had registration problems with my SIP provider.


    The one who worked "best" was Twinkle. I can speak, but i hear nothing.


    Under PanDebian, Twinkle worked perfectly:




    About ALSA, i was told by ED and Notaz that maybe a custom .asoundrc (or system-wide /etc/asound.conf) can create/tweak devices. I didn't succeeded yet, but this info may help you...
     
  12. vandyswa

    vandyswa Member

    Joined:
    Sep 15, 2012
    Messages:
    107
    Location:
    Seattle, WA
    [ALSA custom device]


    Yes, I slowly caught up with those great minds! :->


    I realized hacking the C was silly, and created imic/xmic devices using ALSA's "route" plugin to pick off L or R from


    the hw:0,1 and then offer a mono device. This let my call fire up and things look good, although I have to rebuild with all the debug noise removed and then see if I can get a real, full-duplex call running. As always, I'll keep this topic updated.
     
  13. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,232
    BTW, if you know how to create an ALSA playback device. I miss it in Slackware. I just see record controls.
     
    Last edited by a moderator: Nov 25, 2012
  14. vandyswa

    vandyswa Member

    Joined:
    Sep 15, 2012
    Messages:
    107
    Location:
    Seattle, WA
    Woohoo! Just left a voicemail for myself and it all sounds good. Here's what I added to /etc/asound.conf:


    # Pick Left or Right off the capture audio


    # of the Pandora, offer a mono sound source


    # of that channel.


    pcm.imic {


    type route


    slave {


    pcm "hw:0,1"


    channels 2


    }


    ttable {


    0.0 = 1


    }


    }


    pcm.xmic {


    type route


    slave {


    pcm "hw:0,1"


    channels 2


    }


    ttable {


    0.1 = 1


    }


    }


    With that, I added the following line to .linphonerc:


    alsadev=imic


    (right above playback_dev, though I doubt position matters)


    Then start up linphone and in config/media choose "imic" as your capture device. You should


    then be in business.


    If you're using a four-conductor headset on the front headphone jack, change to use "xmic" instead


    of "imic".


    Note that playback/ringer can just use omap3pandora, the default value linphone will select.
     
  15. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,232
    Nice. I hope i can be inspired by this ^^.
     
  16. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,232
    Thank you dude, you ROCK !


    Now i have working VOIP for my Slackware !!!!!!!!!!!!!!


    I'm so happy, i even authorize you to donate to my project:





    :D :D :D :D :D :D :D :D :D :D
     

Share This Page