Prealpha Release Help


emu parasite kid
Oct 17, 2003
Melbourne, Australia
Visit site
I'm trying out the prealpha gplinux release from and am having problems getting things to launch with the chatboard enabled.

If I use the initrd.nochat file things launch fine if I edit the start file, but if I use and have my chatboard plugged in it launches BusyBox and just sits there with the cursor flashing. I can type commands to look around the directories but cant seem to launch anything even if I remove the # from the front of the line of the app I want in the start file.

I've read the tutorial on the site and the opie thread a couple of times but am still stuck... maybe its my lack of linux knowledge thats holding me back but... any help would be appreciated.

Tristan posted on Sep 14 2004 at 05:28 AM said:
You might want to get a Linux book or something. Linux != DOS.
Anyway, the way to launch files is ./<program filename here>

right... I figured it wasnt going to boot straight into an app and I know enough linux to look around ie. the cd and ls commands and I did try typing commands like "./tetrix" and "./tetrix -qws" but each time it came back with an no such file or directory error... so I figured something is going wrong on my end...

do I have to launch them from a certain dir?

do you really think I should buy a book? :p
Last edited by a moderator:
just keep getting no such file or directory error :(

so... where are the bin files kept?? I thought they would be in /opt/QtPalmtop/bin, but I cant cd to that dir... any help??
hey this is the same problem i have.. (if you look into the moonbuggy thread) i also cant launch anything :(
i get everytime this no file or directory error...
but i dont think that i do something wrong, i use linux on my pc some time now. perhaps there is missing something?
dont know :(

has no one an idea? please ;) its sad that without chatboard everything runs well and now with nothing starts..
yeah I noticed that... good to know its not just me :)

so anybody?

I would really like to get this sorted before downloading any bigger releases on 56k :(

PS-> fast reply rocks :)
if i remember well
you should do something like
cd /mnt/gpmm/linux

you can copy start to start2 start3
and have several start
start mount the libs, set the paths and other settings
and run the prog you want with everthing set as it should be

the not found thing is eihter you misstyped the name
or forget the ./
or the libs are missing, or the path to the libs is not well set
ok.. so you to load the libs manually first.. hehe (im a mandrake debian user which does a nice easy install) i didnt know that i have to do this. Thanks for the info. so what can i do to get things working? i have to find out which libs are needed by a program (this info is available at
and then just add those to the start file.. but do i have to port those libs or can i used precompiled ones for arm on the debian page?
Thanks bye
so ok, i need libncurses5 for my program.. is it possible to add those to the lib090 file? or how can i load those manually later...
Thanks for any help
>do i have to port those libs or can i used precompiled ones for arm on >the debian page?
well, yes. (in most cases)

ok, do you just need ncurses ? then use the libpack
from my wifi pack releases
the ftp client, msn messenger client , ... and other stuff use ncurses

i think you can add manually after
by setting additional path to seek for missing libs

we can load the libs in the init instead of the start [ like in mandrake]
but right now, we are working on some package system
a package system... so something like rpm or deb? will those be compatible?
so for libncurses..
cann i just add the file libopncurssl
with this line?
mmount /mnt/gpmm/linux/libopncurssl /lib -n -t squashfs -o ro,loop
so ... i just try it...
;) ok it worked bu now there is another thing missing .... :( (GLibcC_2.3) is this one in any other package ...
so after this perhaps it runs...
but with this i get a bit more into gplinux, which is fun to try out what works...
if i get some things running perhaps i release a list with working programs ..
and how can i mount a folder on the smc as folder in the system...
mmount /mnt/gpmm/linux/apps/etc /usr/etc -n -t squashfs -o ro,loop
is something like this possible

ok i think squashfs is not possibl cause this sets the file system those lib packages have right?

ok changed the line to:
mmount /mnt/gpmm/linux/apps/etc /usr/etc -n -o ro
but then it gives an error cause /usr/etc doesnt exist... :( but i cant create it cause its readonly filesystem.. i have a problem :D

back to GLIBC_2.3 ... this is used by many programs :(
tried nethack...

with the mount problem... now i just tried this
mount /mnt/gpmm/linux/apps /usr and
mmount /mnt/gpmm/linux/apps /usr -n -o ro and
mmount /mnt/gpmm/linux/apps /usr -n
but now i get this error:
/mnt/gpmm/linux/apps is not a block device.. :-/
so now i dont have any ideas left.. i need help ;)

Ok... i think the mount command is just for devices or file system images, isos or anything but not for folders.... so i remember there was another command for doing what i want to do... but i cant remember which it was
glibc_2.3, is the new one
mhhh i think it s in one of the package
but not the one with ncurses .... mhhhh

cd /var
mkdir sonic
mmount /mnt/gpmm/linux/libsonic /var/sonic -n -t squashfs -o ro,loop
but you dont have a libsonic

so read this
and try to make a start
with LD_LIBRARY_PATH=/mnt/gpmm/linux/sonic/lib
but this doesnt help me to get my etc folder on the smc mounted as an etc folder in /usr
tried symlink but i get a readonly error

perhaps you can remember later in which package the new GCLIB was ;)
argh havent done much with linux for some time now