Beta OpenXcom 1.0.0.13

Discussion in 'Software Releases' started by canseco, Apr 13, 2017.

  1. canseco

    canseco Very Active Member

    Joined:
    Jun 1, 2004
    Messages:
    885
    Location:
    Spain
    OpenXcom 1.0.0.13

    [​IMG]

    OpenXcom is an open-source remake of the popular UFO: Enemy Unknown (X-Com: UFO Defense in USA) videogame by Microprose, licensed under the GPL and written in C++ / SDL.

    Changelog

    0.9.0.19
    - Last git upstream fixes and new features.
    0.9.0.20
    - Last git upstream fixes and new features.
    - Touchscreen offset should be fixed.
    0.9.0.22
    - Last git version. 1.0 coming "soon".
    - Updated previews.
    0.9.0.23
    - Updated to latest language pack from GetLocalization.
    1.0.0.1
    - First stable release.
    - Updated previews.
    - Source included in src folder.
    1.0.0.10
    - Latest git release. It works with UFO or TFTD (not tested) and mods (Final Mod 1.9.6c tested).
    - Updated libs and sources.
    1.0.0.11
    - Fixed version number and deleted previous PND. Thanks to Sepulep for the feedback.
    1.0.0.12
    - Latest git release. It works with UFO or TFTD and mods (Final Mod 1.9.7 tested).
    - Updated libs.
    1.0.0.13
    - Latest git release (18/07/2018). Tested with Final Mod Pack 2.1.

    Link to homepage:
    https://openxcom.org/
    Link to repo:
    https://repo.openpandora.org/?page=detail&app=openxcom
     
    Last edited: Jul 19, 2018
    Tags:
    klapse and _jr_ like this.
  2. canseco

    canseco Very Active Member

    Joined:
    Jun 1, 2004
    Messages:
    885
    Location:
    Spain
    Changelog

    1.0.0.12
    - Latest git release. It works with UFO or TFTD and mods (Final Mod 1.9.7 tested).
    - Updated libs.
     
    PowerGod and atari_afternoon like this.
  3. pmprog

    pmprog Advanced Member

    Joined:
    Apr 25, 2011
    Messages:
    3,833
    Oooh, thanks for the updated version, just need to copy my TFTD files across as well now
     
  4. Hitnrun

    Hitnrun Member

    Joined:
    Mar 1, 2008
    Messages:
    427
    How did you compile this? It seems to require C++11 but the toolchains used for Pandora doesn't support all that it needs.
    I am trying to compile OXCE+.
     
  5. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,397
    Location:
    France, near Lyon
    On the Pandora, with the codeblocks PND I guess, it contains a special command line entry with up-to-date gcc compiler suite (among other things).
     
    canseco likes this.
  6. Hitnrun

    Hitnrun Member

    Joined:
    Mar 1, 2008
    Messages:
    427
    Hmm I tried compiling on the Pandora cmake said it needed an ext2 filesystem, and my sd cards are vfat. Guess I need a new sd card.
     
  7. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,397
    Location:
    France, near Lyon
    Yeah, to build stuff on the Pandora, you need an Ext file system. FAT32 will not really make it and you will have issue, unless you use simple Makefile.
     
  8. canseco

    canseco Very Active Member

    Joined:
    Jun 1, 2004
    Messages:
    885
    Location:
    Spain
    Changelog

    1.0.0.13
    - Latest git release (18/07/2018). Tested with Final Mod Pack 2.1.
     

Share This Page

Loading...