I Don't Understand Alsa!


Hooka

That Guy!
Joined
Jul 19, 2003
Messages
1,745
Age
37
Location
Canada
Website
Visit site
Hey everybody, so the usb-audio kernel module is in, and it's finding my logitec usb hub 2.1. Great!

Now the only problem between my pandora and really loud audio is the fact that I fail at understanding how to tell ALSA/OSS how to use the usb-audio device... I've setup this usb-audio device with pulse audio a few years ago on ubuntu, but nowadays, I just hook it up, go to the sound option and tell it to use both devices and voila, output from my laptop and the usb-audio device.

Are their any alsa guru's who can help me?
 

torpor

hack hack hack, the little machines fight back
Joined
Oct 21, 2005
Messages
2,475
Location
vienna, austria
Website
w1xer.at
Use "aplay -l" to list the devices that are available in your system, and then tell whatever ALSA-compatible media-player you are using to use the new usb-audio device .. it really is that simple! You just need to know the device names/aliases that ALSA has assigned to it, and this should be being done automatically by the usb-audio.ko when its loaded and finds your card ..
 

Hooka

That Guy!
Joined
Jul 19, 2003
Messages
1,745
Age
37
Location
Canada
Website
Visit site
Sweet, works like a charm... now I gotta figure out how I get it to work in, say an emu or game (default oss output somehow I guess...) so when the tv-out cables arrive I can hook it up to the usb-audio and the projector, throw on a couple usb gamepads and be crazy :p
 

Azure

Trust the recursion...
Joined
May 21, 2003
Messages
3,805
Location
California, USA
Hmm...I can't get my Pandora to recognize my DAC (April Music Stello DA100) :( How can I confirm that the usb-audio kernel module is in? I tried "aplay -l" but didn't see my DAC listed (only saw 2 devices listed).
 

torpor

hack hack hack, the little machines fight back
Joined
Oct 21, 2005
Messages
2,475
Location
vienna, austria
Website
w1xer.at
Azure: are you sure that DAC is supported by the snd-usb-audio module device list? If you are sure its a USB-Audio class-compliant device, then it could be that all you need to do is force the module to add the card to its list of supported devices by passing in the Mfr and Device ID's on the command line when you load the snd-usb-audio module .. but do it manually first, then add it to the /etc/modules configuration, which I can't say for sure is the right path as I don't have my Pandora here to check.
 

Loon

Member
Joined
Jul 25, 2006
Messages
357
Got a similar problem with my Altec Lansing USB speakers.

Here is my output from aplay -l

Code:
jon-openpandora:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: omap3pandora [omap3pandora], device 0: HiFi Out twl4030-I2S-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: omap3pandora [omap3pandora], device 1: Line/Mic In twl4030-I2S-1 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Audio [Altec Lansing XT1 - USB Audio], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
jon-openpandora:~$

The Altec Lansing is selected in the system mixer on the task bar as the sound card.

Can´t see what to change in Gnome Mplayer to make it use the USB Speakers.

Anyone got any ideas?
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,670
Age
43
Location
Ingolstadt
Just a guess out of the blue:
Is MPlayer set to use OSS?
I guess the OSS Emulation is still rooted to the normal Pandora speakers, so try setting it to ALSA.
Also, is it not possible to select the output device in Gnome MPlayer?
 

Loon

Member
Joined
Jul 25, 2006
Messages
357
EvilDragon said:
Just a guess out of the blue:
Is MPlayer set to use OSS?
I guess the OSS Emulation is still rooted to the normal Pandora speakers, so try setting it to ALSA.
Also, is it not possible to select the output device in Gnome MPlayer?

Cheers for the suggestions ED but I still can't get it going.

In EDIT,PREFERENCES in mplayer audio output is set to ALSA and default mixer is set to Master. Can't see anywhere to select output device. My logic was that if the soundcard in the system mixer was set to the USB audio device (which it is) then no further configuration would be required.

I'll try some other media players to see if there is an option to select the output device.

I'm pretty sure there is no fundamental problem as when the volume control for the USB device is raised the slight audible hum from the speakers also raises in volume, as per when using the speakers on a windows laptop.

The volume control is listed as PCM in the system mixer.
 
Last edited by a moderator:

torpor

hack hack hack, the little machines fight back
Joined
Oct 21, 2005
Messages
2,475
Location
vienna, austria
Website
w1xer.at
Try changing it from 'alsa' in the preferences, to "alsa:1:0" - for '1' device (the second one), 0'th node ..

Or it could be "hw:1:0" you need to use, I forget ..

EDIT: Per this page: http://www.cse.ohio-state.edu/~bondhugu/alsamch.shtml

.. you should just be able to edit the mplayer config file and specify the device you want to use, explicitly ..
 

Loon

Member
Joined
Jul 25, 2006
Messages
357
torpor said:
Try changing it from 'alsa' in the preferences, to "alsa:1:0" - for '1' device (the second one), 0'th node ..

Or it could be "hw:1:0" you need to use, I forget ..

EDIT: Per this page: http://www.cse.ohio-state.edu/~bondhugu/alsamch.shtml

.. you should just be able to edit the mplayer config file and specify the device you want to use, explicitly ..

Thanks Torpor, tried both of your suggestions altering the audio output setting in Mplayer prefs, when pressing play with the altered settings the MP3 does not play it just says stopped.

Also tried with DeadBeeF media player from the file archive, when selecting the USB audio as the output device under EDIT, PREFERENCES, SOUND then nothing will play as per above.

Just for info, a quick Google Search showed that other people had got these speakers running under linux.

Edit : Torpor, didn't see your edit, can't quite see what to do relating to the linked article, forgive me I'm a total linux noob.
 
Last edited by a moderator:

Loon

Member
Joined
Jul 25, 2006
Messages
357
No luck at my end, gave up after spending a couple of hours fiddling blindly with various settings. See above posts for details.

However the speakers work fine with the USB as the power source and the Headphone jack as the audio source (speakers have aux in), so no big issue for me.
 
Top