Help with Steam Big Picture mode


Advanced Member
Aug 24, 2011
Workington, Cumbria, UK
I'm sure it's something blatantly obvious I'm not doing, but anyway..

Using a GTX 670.. I enable Big picture mode in Steam & then switch input's on my TV.. & my PC deskop is displayed (without icons)..? am I supposed to enable some specific setting in Steam other than just hitting the Big Picture Mode Icon..?

So is big picture mode still showing on your monitor, I would guess that you need to set your tv to be primary monitor.
I know this probably sounds a bit odd, but..

I'm a bit confused as far as the order you're supposed to do things, when I enable the TV as primary display how do I then select Steam? as all the icons on my PC desktop are not displayed on the TV.
Yeh but mirroring mode wont maintain his native tv resolution will it (unless they are both the same) 

Steam by default will open big picture on the primary desktop (where start menu is)  right click desktop and click screen resolution (or properties depending on windows version) and in there you can change your primary monitor to TV then after that open steam big picture, There may be settings in steam to allow it on 2nd monitor(TV) im not sure as im at work.