File System Repair


Jun 20, 2009

I am sure this has been discussed, but I cannot find it anywhere. How does one repair a file/folder on the Pandora? I have a CF card that has a folder I cannot read or delete. I would "fsck" might do it, but it seems that it is not one of the commands that the Pandora Terminal does not use. Is there some other way? Would I have to manually install the fsck command from the tar.bz2 file? Has anyone done it this way?

Is there another program for the Pandora that checks and repairs file systems/files/folders?

Any help is appreciated....
If it's a FAT filesystem, fsck may work but it's usually best to try to repair it on a windoze.
Fsck is included in Zaxxon as default, but you have to launch it as root user.
maybe the folder is from root, and as $user, you can not access it? I have seen directories without permissions being set spontaneously.
If this is not the case, maybe the filename got corrupted and contains non printable characters, in this case try to remove the file by its inode, like so:

sudo su
# action: input password to become root
# cd $correct_directory
# list file/directory by inode (first field)
ls -li
# delete file/directory by inode (using the build-in rm from find)
find . -inum $inum -exec rm -irf {} \;

+1 for gparted.

alternatives: move everything except that directory, remove rm -rf the (almost empty) parent directory, then recreate directory and put other files back...
Another +1 for GParted. I had a partition that wasn't mounting yesterday. GParted's scan/fix worked fine on the Pandora to get it working again.
Yes G-parted has worked well for also. It is what I used to partition my CF card for my Atari Coldfire computer, the Firebee. There is also another nice program for the Win computers called Mini-Partition Tool which also works well.
@superatarian if you find yourself wanting a full Linux environment (with the latest gparted), on your Windows, why not use rufus.exe to create a bootable USB stick using a Linux Life ISO?

(I recommend the ubuntu one. Once you boot from it, press the menu (or the win-key) to get the menu, and type "part", which should be enough to give you a list of icons you can select from. Same for "term", and then "sudo su" to become root without password... now you can lsblk and fsck at will.

note: rufus has a portable version (no need to install it)