Forum Addict!
Oct 3, 2008
OK, lets face it. The DOSBox experience on the Pandora is sub-sub-par. What we have now qualifies as, "Look Ma! I got DOSBox to run - it's saying Hellolo and everything!" Great Alpha ware - but not particularly usable for any realistic application.

-Mouse freeks out.

-Mouse clicks are often 1" or more different from where the cursor is at.

-Keyboard printed characters have nothing to do with what is actually input to DOSBox.

-Vulcan death grip is required to hit even very common keys :) /).

-Simple DOS navigation is impossible without a cheat sheet - the link to which I can no longer find.

So, how do we get this fixed so that we can have a 100% (or near enough to fake it) working DOSBox on the Pandora?
Last edited by a moderator:
Ad 1 and 2:

This is basically fault of SDL that was pointed in here:

The solution is here:

Maintainers of the dosbox should apply a little patch to SDL before compilation to solve this. It cannot be solved on compiled dosbox binary.

Thought i did add it...

for example: cannon fodder is not working properly on dosbox/dboxFE. Mouse is totally inacurate. [btw. i can test more games and add it here]
Last edited by a moderator:
When I installed Windows 3.11, the touchscreen was way off from the pointer.

Ah, yes. Mouse/Touchscreen in Win 3.11 via DB sucks as well. [forgot to mention about it]
Last edited:
There's a modified MOUSE.DRV floating around on GP32X which fixes that, though.
About the keymapping:

I'm not that experienced with Dosbox, but it does offer a keymapper, which I would expect to allow the mapping of the Pandora-keyboard to the corresponding keys within dosbox. Unfortunately you can not access this keymapper via the usual hotkey CTRL+F1 because the outdated and buggy XFCE that is pre-installed does map this hotkey to "Workspace 1". I speak of "buggy" because it is not possible to clear this assignment through the settings-menu at Startmenu->Settings->Desktop->Window Manager although 99% of the Pandora-user wouldn't need that or any other workspace-related hotkey (I doubt that anyone is using more than one Workspace anyway). If you run X without XFCE, (for example when running LXDE instead), then the keymapper in Dosbox can be opened just fine.

It should be possible to set up a default keymap for dosbox without the keymapper-menu though. I assume that there is a simple textfile somewhere in the appfolder that allows reconfiguration by using a text-editor. I didn't try anything further so far.

See also:
Last edited by a moderator:
I have a file "pandora/appdata/dosbox/.dosbox/" which as far as I can tell contains the keyboard-configuration. Not sure if I only got that because I called the keymapper at least once or if everone has that file. I will try to read through it and see if I can make a propper mapping.
So bringing this full circle -

It sounds like there are piecemeal fixes for different issues out there.

Can we get a PND file that has a mapped-to-work-with-Pandora-layout keyboard, working with Pandora nub-mouse driver and all rolled into it so it's seamless?

I know it is a lot to ask, so thank you in advance to whomever tackles it.

Thank you!
I tried to achieve something about the keyboard-mapping, but failed. Either things are too complicated for me or I am thinking into the wrong direction - or both. Here is a bit of information of what I tried: Vogons-Forum
Lets not loose too much momentum on this conversation.

Pickle's DOSBOX launcher (DBoxFE) is a great step forward. I think we can go another two or three steps though.

Pickle - if you're still reading this thread, how hard would it be to add a tab into DBoxFE that would state (and mount) the drive mounts for that profile? Frankly, I like assigning a different drive letter to each application.

What is the deal with the keyboard mapping? Can any one quantify what the actual issue is, why the standard 'mapper' function doesn't work and why the issue exists? Having to do the four button death grip (Left Shoulder, Fn, shift, < ;) every time I need to type a : while navigating DOS isn't user friendly.