Caanoo Game Compatibility Problems (Gpsp + Mame)


Ruzarik

Still Fresh
Joined
Jul 9, 2012
Messages
2
So I bought a caanoo for myself as a gift to cheer myself up from the depression I was going through after a decent concussion and I've been looking at this device long before the injury so I knew what to expect and was so excited to be able to play the games from my childhood on a sexy little device like this.

Anyways, I've got some stuff to work like the PSX, GBC and Sega Genesis, etc. but I've been having a lot of problems finding compatible MAME roms and GBA roms.

My Firmware on the caanoo was 1.6.1 when I got it in the mail last month

GBA problems:
I've been trying so hard to get Pokemon games to work on GPSP v.9.2, Pokemon Emerald and Ruby won't work, they both freeze upon loading and the screen in white and GPSP crashes and sends me back to the menu. Every so often when GPSP crashes it'll crash the caanoo screen completely even when it is in menu. Haven't tried Sapphire, Kingdom Hearts - Chain of Memories freezes at the intro, I've tried to get Emerald to work, so far I've got it to work on VBA on my laptop but it still won't work on the caanoo.

MAME problems:
I honestly got only one game to work, I believe it was 1944 battle over midway but no matter what I do I can't find MAME roms compatible with this version of MAME4all, I've read somewhere that I've got to somehow find MAME roms from MAME version 37b or something.

I found a site called TheOldComputer and they say they've got the rom versions I'm looking for but have to pay $10 to get an unlimited membership to download them, so another source would be appreciated but if they're the only guys who offer it, I suppose I'd be fine with ponying up ten bucks some time in the future for it.

Any help would be hugely appreciated, I'm still somewhat new to this so forgive me if I am doing something stupid here but I've tried for weeks.

Thanks so much guys
 

yoshi41dragon

Active Member
Joined
Jul 9, 2009
Messages
871
Location
ประเทศสวิสเซอร์แลนด์
Sorry to hear about your injury. I hope you are doing well.

Regarding gpSP...

Pokemon Ruby, Sapphire and Emerald have a RTC (real time clock) chip in the cartridge. This is not emulated on the Caanoo. You can try to search the web for a workaround or patch. I don't think there's a solution, but you never know.

Kingdom Hearts has a problem with the intro. Try to save the game state after it crashed. This should bypass the problem (and should work for other crashes as well).

gpSP is not the most perfect emulator on the Caanoo. There are a number of games which don't work.

Regarding MAME4ALL...

Please don't pay anything for MAME ROMs. This is a complete rip-off. I don't know the site you mentioned. But if they really take money, they should be attacked and hacked.

Look for a MAME4ALL ROM set. It's based on MAME 0.37b5 (current versions support ROMs up to MAME 0.37b16).
 

rohezal

Advanced Member
Joined
Oct 18, 2009
Messages
1,690
Here is a solution for an other emulator, i dont think it helps on the caanoo but who knows?

http://www.ehow.com/how_7852962_fix-clock-pokmon-fire-red.html
 

Ruzarik

Still Fresh
Joined
Jul 9, 2012
Messages
2
Thanks!, I have yet to try the roms people have PM'd me but I think they're gonna work possibly...

I've gotten KH: Chains of memories to work actually, I hit "Load savestate" and I'm not sure I even had a save state but it immediately started working flawlessly, Emerald, Sapphire and Ruby have yet to work, Tried so many different methods and save types and tried loading savestates, etc. Nothing works.

Honestly the gpsp needs more work on it, which doesn't look like it will ever happen, who knows.

I've wondered how hard it would be to get linux kernel 2.6 OS's onto the caanoo, since it's already using 2.6, but that will be for another thread.

Anyways, thanks guys for the help. And before I go, I managed to get FireRed to work just fine.
 
Top