WIZ-Toolchein und SDL


relei

Still Fresh
Staff member
Joined
Dec 27, 2006
Messages
1,205
Hallo,

habe noch ein Spiel gefunden, was ich mal für den WIZ geplant hatte, jetzt habe ich aber Probleme beim einrichten der Toolchain. Ich nutze Codeblocks (Linux) und er kennt nach einrichten der Toolchain natürlich #include "SDL/SDL.h" nicht. Kann mir bitte jemand helfen was ich tun muss. Brauche ich extra SDL Libs oder muss ich einfach auf die vorhandenen verweisen.

Ich weiß leider nicht mehr wie ich das damals gemacht habe :-(.

Schönen Gruß und vielen Dank
Rene
 

relei

Still Fresh
Staff member
Joined
Dec 27, 2006
Messages
1,205
Hi,

ich nutze Ubuntu. Geheim ist er nicht, aber ich schäme mich den Code zu zeigen. Wenn man ihn als Schlecht bezeichnet, ist das noch seeeehr wohlwollend.

Ich weiß halt nicht mehr wie ich die SDL-Libs linken muss.

Schönen Gruß
Rene
 

Evil Azrael

Newbie
Joined
Jan 20, 2010
Messages
109
Location
Rheinkilometer 666 & hinter Heidelberg
Website
www.evilazrael.de
ICQ
78819723
WEBSITE
http://www.evilazrael.de
LOCATION
Rheinkilometer 666 & hinter Heidelberg
Die notwendigen Development Pakete mit -dev hast du installiert? Vor allem libsdl1.2-dev. SDL/SDL.h ist im Standard-Include Pfad wenn das Paket installiert ist, man muss mal nix weiter machen: https://packages.ubuntu.com/search?searchon=contents&keywords=sdl.h&mode=exactfilename&suite=zesty&arch=any

Code::Blocks hab ich seit 10 Jahren nicht mehr benutzt, ich nutzen Eclipse/CDT. Wenn du mir das Projekt zukommen lässt, dann schau ich gerne mal rein.

Oh, und noch ein Nachtrag. Versuchst du einen lokalen nativen Build oder dachtest du direkt an einen Crossbuild für eine andere Architektur?
 

relei

Still Fresh
Staff member
Joined
Dec 27, 2006
Messages
1,205
Hallo,

erst einmal vielen Dank. Ich habe natürlich in meinen ersten Post nur die Hälfte geschrieben :). Ich hatte nur Probleme beim Crossbuild. Jetzt habe ich die offizielle Toolchain installiert und ich kann eine gpe erzeugen, aber leider startet diese nicht auf dem WIZ. Habe es auch mit dem 2DTutorial versucht und das startet auch nicht.

Schönen Gruß und Danke
Rene
 
Top