Windows 10

I've tried what feels like every tutorial on creating a bootable USB. Went with dd'ing zeroes to the drive, then fdisk, mkfs.vfat, alternatively gparted, then either dd'ing the iso to the /dev/sd or mounting both and just copying. All those left me with either "not bootable" or "missing OS" when I tried. Gave up yesterday and the first try using woeusb today just worked.
Might be that the problems I had came from upgrading win 8.1 to 10 when it came out. So far even the wifi stick works out of the box without disconnecting.
Next is to figure out how to make dual boot happen with my existing debian SSD.
I found in GPD Win that Debian's GRUB automagically installs in UEFI partition and detects Windows during installation, the systems coexist well at this level.
The problem started when I decided to downgrade BIOS to perform a memory grade tweak, which re-written my UEFI boot partition. GRUB was gone and only Windows started.
I re-booted Live Debian distro, mounted everything and chrooted to Linux partition and reinstalled GRUB from there. Then I was able to only boot Linux through GRUB. After booting to Linux I did auto-detection again by update-grub, it detected Windows and got back to both systems on list.
Why upgrade Win10 to Enterprise to turn the crap off -- when you can do so for free? ShutUp10 is pretty good. My poor 2-core tablet is noticeably faster with "recommended" settings checked off.
I think Windows 3.1 was the best but maybe that's because I used it for so long.

I don't like 10, it's too confusing.
personally i never had any issues with Me... a fresh install with Me drivers and it was stable... upgrades from 98 caused the instability.. when i started at Compaq in 1999 i used Win 98 lite.. win 98 but with win 95 desktop etc... i think the laptop they gave me had a whopping 133MHz Pentium..... my how things have changed.