Urban Terror


meandu229

Zubeman
Joined
Mar 20, 2004
Messages
1,170
Age
34
Location
England(north east)
Website
www.zubeonline.com
Hi


Im loosly following


http://talk.maemo.org/showthread.php?t=66595


to get urban terror working using our IO quake and our folders,


I have it running and can do server browser or start server but it crashes during loading



Code:
rm: cannot remove `/tmp/cpuspeed': No such file or directory

not mounted on loop yet, doing so

LoopMountedon: 

/dev/loop1

Filetype is Squashfs

sudo mount -t squashfs  /dev/loop1

mounting union!

Filesystem is vfat

[------------------------------]{ App start }[---------------------------------]

cp: `default/..' and `.' are the same file

ioq3 1.36_SVN1772M linux-arm Feb 15 2010

----- FS_Startup -----

Current search path:

/mnt/utmp/quake3/.ioq3a/baseq3

./baseq3/zpak000_assets.pk3 (7933 files)

./baseq3/zpak000.pk3 (99 files)

./baseq3/ut4_arena1.pk3 (13 files)

./baseq3/pak8.pk3 (9 files)

./baseq3/pak7.pk3 (4 files)

./baseq3/pak6.pk3 (64 files)

./baseq3/pak5.pk3 (7 files)

./baseq3/pak4.pk3 (272 files)

./baseq3/pak3.pk3 (4 files)

./baseq3/pak2.pk3 (148 files)

./baseq3/pak1.pk3 (26 files)

./baseq3/pak0.pk3 (3539 files)

./baseq3


----------------------

12118 files in pk3 files

execing default.cfg

execing q3config.cfg

execing autoexec.cfg

Hunk_Clear: reset the hunk ok

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

QKEY found.

----- Client Initialization Complete -----

----- R_Init -----

Initializing OpenGL subsystem

Initializing OpenGL extensions

...GL_EXT_texture_compression_s3tc not found

...GL_S3_s3tc not found

...using GL_ARB_multitexture

...GL_EXT_compiled_vertex_array not found

...GL_EXT_texture_filter_anisotropic not found

------------------


GL_VENDOR: Imagination Technologies

GL_RENDERER: PowerVR SGX 530

GL_VERSION: OpenGL ES-CM 1.1

GL_EXTENSIONS: GL_OES_byte_coordinates GL_OES_fixed_point GL_OES_single_precision GL_OES_matrix_get GL_OES_read_format GL_OES_compressed_paletted_texture GL_OES_point_sprite GL_OES_point_size_array GL_OES_matrix_palette GL_OES_draw_texture GL_OES_query_matrix GL_OES_texture_env_crossbar GL_OES_texture_mirrored_repeat GL_OES_texture_cube_map GL_OES_blend_subtract GL_OES_blend_func_separate GL_OES_blend_equation_separate GL_OES_stencil_wrap GL_OES_extended_matrix_palette GL_OES_framebuffer_object GL_OES_rgb8_rgba8 GL_OES_depth24 GL_OES_stencil8 GL_OES_compressed_ETC1_RGB8_texture GL_OES_mapbuffer GL_OES_EGL_image GL_EXT_multi_draw_arrays GL_OES_required_internalformat GL_IMG_read_format GL_IMG_texture_compression_pvrtc GL_IMG_texture_format_BGRA8888 GL_EXT_texture_format_BGRA8888 GL_IMG_texture_stream GL_IMG_vertex_program 

GL_MAX_TEXTURE_SIZE: 2048

GL_MAX_TEXTURE_UNITS_ARB: 4


PIXELFORMAT: color(0-bits) Z(0-bit) stencil(0-bits)

MODE: 3, 800 x 480 fullscreen hz:N/A

GAMMA: software w/ 0 overbright bits

rendering primitives: single glDrawElements

texturemode: GL_LINEAR_MIPMAP_NEAREST

picmip: 1

texture bits: 0

multitexture: enabled

compiled vertex arrays: enabled

texenv add: enabled

compressed textures: disabled

Initializing Shaders

----- finished R_Init -----

------ Initializing Sound ------

SDL_Init( SDL_INIT_AUDIO )... OK

SDL audio driver is "alsa".

SDL_AudioSpec:

  Format:   AUDIO_S16LSB

  Freq:     22050

  Samples:  1024

  Channels: 2

Starting SDL audio callback...

SDL audio initialized.

----- Sound Info -----

    1 stereo

32768 samples

   16 samplebits

    1 submission_chunk

22050 speed

0x1ad1f10 dma buffer

No background file.

----------------------

Sound initialization successful.

--------------------------------

Sound memory manager started

Loading vm file vm/ui.qvm...

Architecture doesn't have a bytecode compiler, using interpreter

ui loaded in 35056608 bytes on the hunk

UI menu load time = 7979 milli seconds

UI menu load time = 6199 milli seconds

16 bots parsed

13 crosshairs parsed

--- Common Initialization Complete ---

IP: 127.0.0.1

IP6: ::1

Opening IP6 socket: [::]:27960

Opening IP socket: 0.0.0.0:27960

35 arenas parsed

------ Server Initialization ------

Server: ut4_abbey

RE_Shutdown( 0 )

Hunk_Clear: reset the hunk ok

----- R_Init -----


GL_VENDOR: Imagination Technologies

GL_RENDERER: PowerVR SGX 530

GL_VERSION: OpenGL ES-CM 1.1

GL_EXTENSIONS: GL_OES_byte_coordinates GL_OES_fixed_point GL_OES_single_precision GL_OES_matrix_get GL_OES_read_format GL_OES_compressed_paletted_texture GL_OES_point_sprite GL_OES_point_size_array GL_OES_matrix_palette GL_OES_draw_texture GL_OES_query_matrix GL_OES_texture_env_crossbar GL_OES_texture_mirrored_repeat GL_OES_texture_cube_map GL_OES_blend_subtract GL_OES_blend_func_separate GL_OES_blend_equation_separate GL_OES_stencil_wrap GL_OES_extended_matrix_palette GL_OES_framebuffer_object GL_OES_rgb8_rgba8 GL_OES_depth24 GL_OES_stencil8 GL_OES_compressed_ETC1_RGB8_texture GL_OES_mapbuffer GL_OES_EGL_image GL_EXT_multi_draw_arrays GL_OES_required_internalformat GL_IMG_read_format GL_IMG_texture_compression_pvrtc GL_IMG_texture_format_BGRA8888 GL_EXT_texture_format_BGRA8888 GL_IMG_texture_stream GL_IMG_vertex_program 

GL_MAX_TEXTURE_SIZE: 2048

GL_MAX_TEXTURE_UNITS_ARB: 4


PIXELFORMAT: color(0-bits) Z(0-bit) stencil(0-bits)

MODE: 3, 800 x 480 fullscreen hz:N/A

GAMMA: software w/ 0 overbright bits

rendering primitives: single glDrawElements

texturemode: GL_LINEAR_MIPMAP_NEAREST

picmip: 1

texture bits: 0

multitexture: enabled

compiled vertex arrays: enabled

texenv add: enabled

compressed textures: disabled

Initializing Shaders

----- finished R_Init -----

NET_JoinMulticast6: Couldn't join multicast group: No such device

----- FS_Startup -----

Current search path:

/mnt/utmp/quake3/.ioq3a/baseq3

./baseq3/zpak000_assets.pk3 (7933 files)

./baseq3/zpak000.pk3 (99 files)

./baseq3/ut4_arena1.pk3 (13 files)

./baseq3/pak8.pk3 (9 files)

./baseq3/pak7.pk3 (4 files)

./baseq3/pak6.pk3 (64 files)

./baseq3/pak5.pk3 (7 files)

./baseq3/pak4.pk3 (272 files)

./baseq3/pak3.pk3 (4 files)

./baseq3/pak2.pk3 (148 files)

./baseq3/pak1.pk3 (26 files)

./baseq3/pak0.pk3 (3539 files)

./baseq3


----------------------

12118 files in pk3 files

Loading vm file vm/qagame.qvm...

Architecture doesn't have a bytecode compiler, using interpreter

qagame loaded in 37410880 bytes on the hunk

------- Game Initialization -------

gamename: q3ut4

gamedate: Dec 21 2007

2 teams with 31 entities

-----------------------------------

-----------------------------------

RE_Shutdown( 0 )

----- R_Init -----


GL_VENDOR: Imagination Technologies

GL_RENDERER: PowerVR SGX 530

GL_VERSION: OpenGL ES-CM 1.1

GL_EXTENSIONS: GL_OES_byte_coordinates GL_OES_fixed_point GL_OES_single_precision GL_OES_matrix_get GL_OES_read_format GL_OES_compressed_paletted_texture GL_OES_point_sprite GL_OES_point_size_array GL_OES_matrix_palette GL_OES_draw_texture GL_OES_query_matrix GL_OES_texture_env_crossbar GL_OES_texture_mirrored_repeat GL_OES_texture_cube_map GL_OES_blend_subtract GL_OES_blend_func_separate GL_OES_blend_equation_separate GL_OES_stencil_wrap GL_OES_extended_matrix_palette GL_OES_framebuffer_object GL_OES_rgb8_rgba8 GL_OES_depth24 GL_OES_stencil8 GL_OES_compressed_ETC1_RGB8_texture GL_OES_mapbuffer GL_OES_EGL_image GL_EXT_multi_draw_arrays GL_OES_required_internalformat GL_IMG_read_format GL_IMG_texture_compression_pvrtc GL_IMG_texture_format_BGRA8888 GL_EXT_texture_format_BGRA8888 GL_IMG_texture_stream GL_IMG_vertex_program 

GL_MAX_TEXTURE_SIZE: 2048

GL_MAX_TEXTURE_UNITS_ARB: 4


PIXELFORMAT: color(0-bits) Z(0-bit) stencil(0-bits)

MODE: 3, 800 x 480 fullscreen hz:N/A

GAMMA: software w/ 0 overbright bits

rendering primitives: single glDrawElements

texturemode: GL_LINEAR_MIPMAP_NEAREST

picmip: 1

texture bits: 0

multitexture: enabled

compiled vertex arrays: enabled

texenv add: enabled

compressed textures: disabled

Initializing Shaders

----- finished R_Init -----

Loading vm file vm/ui.qvm...

Architecture doesn't have a bytecode compiler, using interpreter

ui loaded in 35056608 bytes on the hunk

UI menu load time = 8305 milli seconds

UI menu load time = 6602 milli seconds

16 bots parsed

13 crosshairs parsed

Loading vm file vm/cgame.qvm...

Architecture doesn't have a bytecode compiler, using interpreter

cgame loaded in 36837760 bytes on the hunk

ALSA lib pcm.c:7234:(snd_pcm_recover) underrun occured

ALSA lib pcm.c:7234:(snd_pcm_recover) underrun occured

ALSA lib pcm.c:7234:(snd_pcm_recover) underrun occured

./runioquake3.sh: line 3:  1794 Killed                  ./ioquake3.arm +set x11 1

[-------------------------------]{ App end }[----------------------------------]

cleanup done


That is the output of the pnd when I tried to run start a server.


Any ideas anyone


It crashes after it loads the sounds it moves onto loading the map then dumps back to desktop.


Edit: i used hunkmegs 175 as 256 crashed on me,
 
Last edited by a moderator:

notaz

Certified Guru
Joined
Aug 23, 2005
Messages
4,913
Location
Lithuania
Website
notaz.gp2x.de
Could be still out of memory (check dmesg), also try running it under gdb (unpack the .pnd and run from the terminal).
 

darfgarf

Well-Known Member
Joined
Dec 8, 2009
Messages
1,125
Age
31
Location
Blighty
Website
www.gfrancisdev.co.uk
hmm, no real ideas apart from memory issues, or something just failing and needing some gdb magic (and hoping quake hasn't been stripped of course)


i'll offer any help i can think of though, urban terror goes down a treat at lan parties, really is bloody good
 

Mr_Loon

Can't Remember
Joined
Aug 30, 2010
Messages
2,330
Sounds like an excellent game for Pandora.


My understanding is the Urban Terror is a derivative of Quake 3. Sadly Quake 3 is currently unplayable on Pandora due to it being more or less uncontrollable with the nubs.


If you could add mouse control to Pandora Quake 3, and of course Urban Terror, you'd be a Pandora hero in my eyes.


Sorry for the slightly cheeky request, no worries at all if it's not something you'd be interested in doing.
 

meandu229

Zubeman
Joined
Mar 20, 2004
Messages
1,170
Age
34
Location
England(north east)
Website
www.zubeonline.com

TrashyMG

Sarcasm Dispenser
Staff member
Joined
Jan 18, 2010
Messages
11,088
After some fighting I got it working


thanks for link 512mb swap on my card seemed to work,


Next problem I cant type into the console, I can open it and press enter but not type, so I cant add any bots,


Does IOQuake change the keyboard into a gamepad or something?

Sounds like the same issue I had with Ioquake3 when running it on the beagleboard and that was using a USB keyboard.. unfortunately I never did get any time to play with it further.
 
Last edited by a moderator:
Top