Ubuntu Won't Recognise Gp2x


tom12519

Still Fresh
Joined
Jun 22, 2006
Messages
11
I insert SD card, can view photos on it etc. however when connected to my Ubuntu machine, it is not recognised...
 

Alvin

Member
Joined
Mar 26, 2006
Messages
171
$ su
Password: <root password goes here>
# mkdir /mnt/sd
# cd /mnt/sd
# mount /dev/sdb1 ./

That'll mount the SD card (/dev/sdb) to /mnt/sd, it might not be sdb for you. If you have a SATA HD, it most probably will be if you don't have any other mass storage devices in, otherwise if you have a different type of HD, it'll most likely be /dev/sda, providing you have no other mass storage in. Remember to specify /dev/sd*1, else it will complain about invalid block devices or something.
Before you rip it out, do:
# umount /mnt/sd
If it says it's busy, but you're not copying anything, it's usually safe to take it out then.

You'll have to be root to put stuff on it. I suggest running something like
# nautilus ./
(providing /mnt/sd is your working directory), then you can drag and drop files from other applications without permissions.

This is assuming you have a USB card reader.

If that fails, have a look at what syslogd says when you plug it in. If nothing happens (to do with hald or whatever), try a different port.
 

tom12519

Still Fresh
Joined
Jun 22, 2006
Messages
11
Hmm, I'll try to get my hands on an SD card reader rather than trying to use the direct GP2X interface, as that didn't seem to work, still...
 

Alvin

Member
Joined
Mar 26, 2006
Messages
171
Oh, you're using the GP2X interface?
Hm, this should still work, as it's also USB, but I do suggest getting a card reader, they're really cheap (I got mine for £5), as they're a lot faster than the GP2X transfer.
 

tom12519

Still Fresh
Joined
Jun 22, 2006
Messages
11
Well, I'll have to save up some money... But also, what can you connect to the ext port apart from a breakout board?
 

Feeg

Still Fresh
Joined
Apr 29, 2006
Messages
99
Age
38
Location
Sydney, Au
Website
Visit site
You might have more luck on the Ubuntu forums - lotsa friendly people on there.

Describe it as a problem with a USB mass storage device not being detected. If you're lucky they'll help you to provide them with some diagnostic info. You might need to add support to your kernel if you've got some kind of weird motherboard.

The problem isn't your distro exactly - assuming you're using a relatively new version of Ubuntu - but more likely to be some strange hardware which isn't being detected properly.

Good luck.

// auto-merged, how weird:

Whoops - additionally you can connect anything to your ext port that you can connect to a breakout board, but you need to build a custom cable using a connector found on some mobile phone serial connectors - check the gp2x wiki for phone models known to work, bone up on your soldering skills and find a phone shop that sells the phone cable.

BOB might be more cost effective though, if you buy from an actual mobile phone accessory shop. Retail prices around here are like ~$40 au, plus whatever components you need. But I suspect that a home built cable wins if you're trying to make something portable.

Using the same ext connector you should be able to add JTAG for accessing the chipset, but I don't know anything about that stuff. Again, wiki it up.
 

___

Advanced Member
Joined
Jan 31, 2006
Messages
3,376
seems like it. can't access it either. Maybe maintenance...
 

Super Jamie

Still Fresh
Joined
Feb 26, 2007
Messages
80
Age
39
Location
Brisbane, AU
Website
linuxaleph.blogspot.com
this is an old topic, but still comes up in google search for "ubuntu gp2x", and with increasing adoption of linux as a desktop OS, i thought it might be relevant


firstly, you need to update to usb networking kernel module on your gp2x. the one that ships with it only works with 2.4.x kernels, and most linuxes these days run 2.6.x

to do this, grab a g_ether.o from any 2.6.x distro or kernel.org, or one is provided here. make a file on your gp2x called usbnet.gpu, and put this in it:
CODE
#!/bin/sh

rmmod g_ether
cp -f g_ether.o /lib/modules/2.4.25/kernel/drivers/usb/gadget/g_ether.o
sync

modprobe g_ether
cd /usr/gp2x
exec ./gp2xmenu


then run it. this will update your gp2x. plug it in, turn on usb networking, run ifconfig usb0 up 192.168.0.1 or whatever ip address is relevant on your pc, and you should be able to communicate with gp2x

(yes, this is all ripped straight from this wiki page, but is helpful for google searchers, or if the wiki page is down)


now i'd done all this on my laptop, and gp2x was working fine, but i couldn't get it going on my desktop pc. turns out it was the hardware in the pc causing the issue. specifically, i have a motherboard with an nForce chipset, which i found out (by googling "ubuntu nforce usb") is not very good at detecting usb devices under current (2.6.20) linux kernels. i first suspected it was something beyond the gp2x when none of my usb card readers would detect over 1gb, even though i was using known working 2gb/4gb/8gb sd and cf cards

my solution in this case was to install a pci usb2 card with a different chipset (via in my case, though any would do), now all my card readers detect fine. still no gp2x tho, i'm guessing there are still kernel issues with that


i hope someone finds these experiences helpful
 

sephiroth111

Member
Joined
Mar 2, 2006
Messages
139
it might be worth noting to sync it before disconnect. before typing the unmount, just type "sync" and then unmount it. this ensures it was written.
 

Super Jamie

Still Fresh
Joined
Feb 26, 2007
Messages
80
Age
39
Location
Brisbane, AU
Website
linuxaleph.blogspot.com
got gp2x detected fine, i had to disable usb2

sudo modprobe -r ehci_hcd does the trick

further to sepiroth's post, you should always unmount the usb drive before unplugging the gp2x or clicking X to disconnect it
 
Top