[Solved] Sd Mass Storage Mode


Jul 23, 2009

I have never been able to sucessfully use my Pandra as a SD card reader. It should be really simple but there seems to be something fishy going on anyways...

What I do:
  1. Boot up Pandora, HF4 installed
  2. Run the script 'System->SD-Mass Storage'
  3. Choose my 32GB card in slot 2: /media/SD_32GB
  4. Press 'OK'
  5. The dialogue 'SD Card /media/SD_32GB is currently in Mass Storage Mode. Click on ....blabla' popps up
  6. I connect a miniUSB cable (that I normally use for charging) to the OTG port and to my WinXP desktop (tried another WinXP and Win7 as well, all same results)
Windows komplains that there is an unknown device connected. I cannot access the SD card ;(

lsmod tells me that with the script beeing loaded, g_cdc module is unloaded and g_file_storage loaded instead (no other g_* module loaded).

Am I doing something wrong? Does the mass storage mode work for all you guys with a Pandora out there?
Gruso said:
Have you tried connecting the cable first? That's how I do it.

Yes, that doesn't change anything. But you are saying you're doing the exact same things I do (apart from the connecting cables) and it just works on a windows desktop?

I just found out that the cable is capable of charging my Pandora, but it seems it doesn't do much data-channeling.. Changing the cable finally got the sd storage mode working, hurray!
@ Mods: pls delete thread or mark it [solved], thx ;)

Updated http://pandorawiki.org/USB_reference#Pandora_as_USB_slave ;)
Last edited by a moderator: