Sd Slot 2 Not Working


Active Member
Sep 11, 2008
Visit site
I was transfering some files to my sd and to do this i need to take my sd out and put it in another device so i can transfer stuff to it via windows ,mass storage is so far not working for me ,i have only started using hotfix 3 today so i haven't had a lot of time to test.

Anyway - on reinserting my sd to sd slot 2 nothing happens ,this has never been a problem before ,the card is still detected in windows fine and also is detected in sd slot 1 fine ,on sd slot 2 the led blinks very dimm and nothing is mounted ,i have tried a full removal of the batttery and reboot.

update - mass storage now working for me ,i reinstalled the hotfix and rebooted so that is a very good thing ! i have also formatted my sd just to be on the safe side as i was transfering a large file to the card just before this happened but the card seems fine ,just the slot is bad :(
Is there anything else i could test to check the slot,i think it could be software as i had to format my card not s long ago as the partition table was messed up and the card would not appear but since i formated with the hptool after creating a new table everything seemed perfectly fine.The card does look fine but at the same time i have seen this same problem when i was trying to get my card working when it had 2 partitions on it,it would mount on one slot and not on another.

It is strange as everything was fine and all i done was put a file on the card and then back again,im sure i had done that earlyer yesterday as well and also a few times when i was flashing the firmware but the only thing i can think of is that i tried to transfer a file that was too large for the sd card and got the error near the end of the transfer telling there was not enough space,i checked the card and i still had all my space as it couldn't actuly transfer the file.

But then again just to test i have formatted my card again,it reads perfecly on sd1 and on my desktop and my camera.
pandora:~$ dmesg|tail
[ 268.602630] end_request: I/O error, dev mmcblk1, sector 0
[ 268.608978] mmci-omap mmci-omap.1: MMC IRQ 0x208000 : ERRI DCRC
[ 268.609039] mmcblk1: error -84 transferring data
[ 268.613708] end_request: I/O error, dev mmcblk1, sector 7774200
[ 268.620483] mmci-omap mmci-omap.1: MMC IRQ 0x208000 : ERRI DCRC
[ 268.620544] mmcblk1: error -84 transferring data
[ 268.625244] end_request: I/O error, dev mmcblk1, sector 7774200
[ 268.632019] mmci-omap mmci-omap.1: MMC IRQ 0x208000 : ERRI DCRC
[ 268.632110] mmcblk1: error -84 transferring data
[ 268.636779] end_request: I/O error, dev mmcblk1, sector 7774200
Yes Ed the same sd works on sd slot 1,when inserted in slot 1 the led blinks as normal but in slot 2 the led is very dimm faint flicker for about 1 second.
the card seems to be perfectly fine in my camera,windows xp and ps3 and also fine in slot 1 and it was fine in slot 2 untill last night when the card was removed so i could transfer a file to the card.
have you tried any other card in the slot than the card giving trouble? could be it has issues and the system is recognising it from it's device ID or something and refusing to use it , yes, it's a odd idea, but computers are odd all round :p (imo), ever noticed how they lull you into a false sense of security and then throw you a curve ball the instant you offer to do a "simple fix" for someone? , possessed they are :eek: , sheerly demonic :ph34r:
I had asked for help in another thread about formatting the card but i got mixed advice,i would like to do a full format via the pandora to reset delete and create a new table and partition (again) as to show the card is set up the best it can be,would this help ?

I know what you are saying hobbyman i was also thinking the same,i would like to remove all possibilities,also i don't have another sd but i have a microsd and sd converter card.

just to confirm,i have now tried my grrr psp 32gig micro sd,it ment formatting all my stuff,but i guess i had to know,anyway my microsd also only works on sd1,doesnt work on sd2 slot so hell knows i recon my sd slot is damaged.

i am now going to try one final thing and that would be flashing the firmware,if that doesn't work then it must be a hardware issue.
Someone definitely should get gparted going and upload a PND or better yet include it in the firmware, imo. These SD Card problems should be wiped out as soon as possible.
Ok time to move on,full reflash completed and both my cards only work on sd slot 1 ,sd slot 2 not working at all,should i email OPT
^ Have you got a compressor or a "can of air"(still can't believe such things exist, lol) at hand? Maybe you just got some dirt inside the slot.
I tried one of my broken cards and got similar messages, however, in this case it might be the slot itsethats broken.
or well, most likely, since the same card works in other devices.
Hi,i need to send my pandora back but its going to be around two weeks to test and repair my unit and i really don't want to be without my pandora for that lenth of time so i am asking if any you guys have any other suggestions that i could try on a software level to see if i can infact get my card to read on slot2.

I am asking partially in a desperate attempt to fix this without sending it away but also because i found that my other sd card,a micro sd 16gb card was formatted and working in sd slot 1 but just today it stopped working in slot 1 but would still load up fine in windows and also that card shows up on slot1 if i hold down the right shoulder button at boot to flash the pandora firmware,so i think something strange is going on that my cards are just vanishing.

Mabe my cards are not formatted correctly
Mabe the old id for those cards are somehow not showing up in the OS
Mabe i am really unlucky and my cards have been damaged ????
Mabe my pandora has some crazy hardware fault

^ Format the cards with the tool from the tweaks thread, reflash and install hotfix 2. If you don't have a windows PC at hand to use that tool, find a friend who does. If it is working then, report the issues in the hotfix 3 beta testing thread.
I doubt I can help much, but if I may throw my hat in the ring briefly anyway: What sort of cards are you using (i.e., what brand), and where did you get them? Also, do you have any spare cards that you could check with?

And one other thought: Have you modified anything or installed any new updates recently? If so, could those possibly have any bearing on this? (I suppose that's something that someone more knowledgeable than I would be able to determine, though. :p I'm probably barking up the wrong tree on both counts. :lol: )

EDIT: Ninja'd by mali, and much more succinctly and eloquently, too! :lol: Ignore my post. :p
mali said:
^ Format the cards with the tool from the tweaks thread, reflash and install hotfix 2. If you don't have a windows PC at hand to use that tool, find a friend who does. If it is working then, report the issues in the hotfix 3 beta testing thread.

I had formatted them with hp format tool in fat32 ,i am going to format them both using gparted in ext2 ,they should pick up no bother in the OS so if they don't then it must be hardware ,plus i will do it with both cards to eliminate sd card manafacturer.

my original card had always worked since i got my first pandora unit ,i really don't know why this has happend and i have since flashed the pandora firmware twice now and it's the same issue ,this is why i was thinking mabe my cards were mabe not properly formatted with the correct table.

My guess is there are no more pandora units left as i was told OPT are only repairing units now instead of replacing ,i am actuly a bit anoyed by that as i sware i wish i had keptmy old unit, the new unit is far worse in build quality and this is a much newer unit in the line ,i already read more people getting their pandora's yesterday and today with brpken nubs as well ,i recon the nubs are simply a bad design and a bad choice for OPT to have ordered those type of nubs ,not really OPT fault but not good at the same time ,as for me i have a poor looking pandora with one faulty nub and one faulty sd slot prolly ,a messed up stylus that i can't use and a touch screen display that isn't as responsive as my last one and then there's the right shoulder button ,well that could be better and also my XY game buttons are spongy as hell with no travel.

hmm what the hell am i chasing ? this isn't a dream handheld :(

btw ,sorry if this makes me sound like i should be given a nice new pandora every time something goes wrong ,i understand the team have limited numbers and it IS more important these units go out to as many people as possible ,just feel a bit let down.
Last edited by a moderator:
Alerino said:
Assembly curse?
i'm glad i didn't join the team, :D

well, for me here, i'm still dreaming, everything works perfectly (except wifi :D )

really m8 i am happy for you ,and can't quite believe you have 2x working nubs !! do they do full circles more than 3 times in a row without going a bit crazy? lol naa really enjoy your pandora and i hope in the future everyone can enjoy their pandora. :)
Last edited by a moderator: