Mapper.txt And Dosbox.conf Repeatedly Corrupted

gnarface

Still Fresh
Joined
Feb 23, 2011
Messages
14
Location
USA
I seem to be having a new issue with Dosbox and it only seems to happen with a specific game; Ultima VI. Basically every time I run this program after painstakingly attempting to create a correct mapper.txt file and dosbox.conf for it I end up with directional controls that don't match what I put in mapper.txt. When starting the game directional controls are then always partially scrambled: "left" switched with "down" for example is common. When I quit the game (whether I quit Dosbox, CTRL-q from within the game or just shut the WIZ down using the power switch) I discover that my mapper.txt and often the dosbox.conf as well have been changed! The changes sometimes make sense (like they are an older version of the file reappearing somehow) and sometimes just seem like arbitrary remappings. When I fsck the filesystem (fsck.msdos -r -w -v -V /dev/sdb) of course in this case it discovers errors and seems to only be able to correct them by making the corrupted mapper.txt and/or dosbox.conf empty 0-byte files. This does not seem to be happening with other games in Dosbox, nor does it seem to be happening with any other emulators, although Ultima VI does run very slow compared to most the other games I have used so maybe it is a race condition problem of some sort? I'm just guessing here. The issue has not appeared on my Linux install of Dosbox using the same installed game directory however that is a more recent version of Dosbox than the WIZ port is based on. Has anyone else seen this issue with Dosbox or have any ideas how to address it other than just avoiding Ultima VI? Any advice is appreciated.

Thanks in advance.

UPDATE: I found out something that may be related here. I happened to notice that if I run "ps" in a terminal on the WIZ after I exit Ultima VI the process list clearly still includes the running instance of my Ultima_VI.gpe script. If I start and exit Ultima VI again without killing it, then the process list will show both instances of the Ultima_VI.gpe script. Something is making it stay open but my dosbox.conf for the game has "exit" as the final line so I'm not sure what that could be, but it seems that this may be related to the intermittent corruption of the dosbox.conf and mapper.txt for Ultima VI.
 
Top