Caanoo / WIZ I Need Some Libs In Fault On The Wiz Toolchain


Geca

Member
Joined
Sep 6, 2010
Messages
338
Age
42
Location
Madrid, Spain
Website
www.gecasoft.no.sapo.pt
Hi, I need some libs in fault on the Wiz Toolchain.

The libs I need compiled to Gp2x Wiz, are:

- zlib (-lz)

- sdl Image (-lSDL_image)

- Unicode Font (-lunicodefont)

Someone can help me to find them ?
Thanks.
 

HunterZ

Member
Joined
Feb 27, 2011
Messages
150
Location
Seattle
Which toolchain are you using, and have you followed all of the directions for installing it and setting up your environment to use it?

If you're trying to compile an existing project, have you edited the makefile to point at your toolchain?
 

Geca

Member
Joined
Sep 6, 2010
Messages
338
Age
42
Location
Madrid, Spain
Website
www.gecasoft.no.sapo.pt
I use the oficial sdk

I have 2 problems, they find the lib, but the message is this:

1 -

warning: libm.so.6, needed by /home/geca/Geca/legacy/GPH_SDK/tools/gcc-4.0.2-glibc-2.3.6/arm-linux/bin/../lib/gcc/arm-linux/4.0.2/libstdc++.so, not found (try using -rpath or -rpath-link)


2 -

I don't have the libm.so.6 in the libs folder, but I find this lib compiled for Wiz, and if I put this lib, I got this error:

/home/geca/Geca/legacy/GPH_SDK/tools/gcc-4.0.2-glibc-2.3.6/arm-linux/bin/../lib/gcc/arm-linux/4.0.2/../../../../arm-linux/bin/ld: ERROR: /home/geca/Geca/legacy/GPH_SDK/tools/gcc-4.0.2-glibc-2.3.6/arm-linux/bin/../lib/gcc/arm-linux/4.0.2/libm.so uses FPA instructions, whereas bin/legacy does not

Any solution ?
Thanks.
 

HunterZ

Member
Joined
Feb 27, 2011
Messages
150
Location
Seattle
Looks like you installed it in a weird place. Here are the official instructions for setting up the official toolchain: http://git.fungp.com/

Note that you need to run the "export PATH=/opt/toolchain-wiz/bin:$PATH" once before the first time you want to use the toolchain in a terminal. You don't want to put this in your login scripts because it might mask some of your native Linux development tools.
 
Top