Gp2x


Coder_TimT

Member
Joined
Mar 17, 2006
Messages
288
[EDIT]
Okay, I've been unable to stop myself working on this. I managed to get the backlight working to a point(manually attached each led to the lcd casing; lost two leds along the way and you can see the points of light coming up), but somewhere along the way apparently managed to brick the unit. So below it what it currently looks like. Murphy's Law has been with me the whole time on this one...

[EDIT 2]
Just wanted to make clear that the lcd and backlight still probably need replacing. My poor backlight fix is "iffy" at best and keeps cutting out so there is either a loose connection or short. So there is still work that will have to take place in that regard. Also, one of the speakers came disconnected and I just don't feel like soldering it back on at this point...if you can handle the backlight, you can definatly get that reconnected though.

$55 shipped to US. $75 shipped worldwide. Paypal only.




[ORIGINAL POST]
What started off as a quest to fix what appeared to be a bad connection to the lcd backlight turned into a torn connector and finally a mess of poor solder trying to get the backlight into at least a functional state. The soldering was way out of my league.

Anyway, here's a pic to show it was still working just without backlight. Basically it's going to need a new lcd. If you really know what you're doing you might could salvage the lcd with a replacement backlight, but I made a pretty good mess of things while I had it apart. Or salvage for parts...
[/ORIGINAL POST]
 

Coder_TimT

Member
Joined
Mar 17, 2006
Messages
288
The cable that powers teh backlight tore off right as it enters the lcd. I'm am about to edit my original post since I've actually hacked the backlight back on, but somewhere along the line the unit appears to have gotten bricked as I'm just getting multicolored horizontal lines when powering up now.
 

(naw)mcx

Rotary Wombat
Joined
Dec 3, 2005
Messages
2,918
Age
27
Location
Aberdeenshire
Website
www.godlikemcx.deviantart.com
Coder_TimT posted on Apr 8 2006 at 10:00 PM said:
The cable that powers teh backlight tore off right as it enters the lcd. I'm am about to edit my original post since I've actually hacked the backlight back on, but somewhere along the line the unit appears to have gotten bricked as I'm just getting multicolored horizontal lines when powering up now.


Tryed changing batterys???
 
Last edited by a moderator:

Coder_TimT

Member
Joined
Mar 17, 2006
Messages
288
(naw)mcx posted on Apr 9 2006 at 02:57 PM said:
Tryed changing batterys???

Yep. It's definately not a battery problem. Thanks.
 
Last edited by a moderator:
Top