Four Conductor Headset - Alsa setting - asoundrc


Well-Known Member
Aug 11, 2007

I'm struggling with audio settings in Alsa (.asoundrc) to make this headset function properly. Microphone works ok (Sub Mic as Right Input Source), though output sound seems to be missing a channel (sounds like it is inside a pipe, distant sound). When i press on/off button (cuts mic input), sound plays perfect.



Any ideas? Merge/swap channels? Pulseaudio?

thanks for any help
Last edited by a moderator:
First and foremost: what does the package say the headphones are compatible with?

If it says "iPhone" you may be out of luck. They don't use a standard connection, instead swapping around two of the wires, just to force you to buy their "proprietary" plug. You can probably find some information on it to splice the wires yourself, if you want.

If it's not iPhone compatible, then... I dunno.
One more reason to dislike Apple, but yeah. I had the same problem. You need to swap the mic and ground leads. Usually it's pretty easy to do inside the housing for the mic on/off button and just takes a tiny amount of skill with a soldering iron. If I can do it in on a caffeine high anyone can. :)
damn, think i'll buy a nokia headset then, my engineering skills are close to zero, i just mess with rca, p2, etc, no soldering B)

If you can figure out what color wire is the mic, you can do a simple slice and splice as well. The ground wire is surely the one without any sort of wrapping. I just found that just heating up the existing solder and swapping the leads was cleaner. The problem with those tiny ear buds like that is the wires are often super thin, and very fiddly. Like I said though, I too have next to zero skill with an iron, and I was jamming a serious caffeine buzz and I still pulled it off. :)
The built in MIC has worked for me, just need change the recording device in the mixer and up the boost level. Never tried the plug, but I saw the option in the mixer setting to change to that.

To be fair I was doing some recordings directly with alsa via command line.. I never tried Audacity with it.

Someone was complaining in the support forum, but sounds like he/she actually had a defective internal MIC.
Last edited by a moderator: