Firmware V2.1.1


Certified Idiot :)
Jan 11, 2004
London, UK
GPH have released a new firmware v2.1.1. As you need to be a Korean resident to download from the Korean homepage I have uploaded it to the archive at,0,0,0,42,1903.

This version apparently fixes some bugs related to mp3 playback and one to do with headphones. If you are not sure how to install the update, download my guide at,0,0,0,23,933 and replace any references in the firmware updating guide for v2.1.0 firmware with v2.1.1. I will update the guide in a day or two once I have done some other changes for it.
In mplayer fixed bug! On the top-right i have graph bug and now i don't have =)
mp3's that played at half speed are working fine now. Seeking thru a audio file is very slow since 2.1.0 but is consistant.
Babelfish says :

How are you the game park hall ting su is.
The GP2X the F-100 up-to-date firmware 2.1.1 version was updated.
It is a firmware patch which solves the problems which in 2.1.0 versions get after firmware updating.
The detailed improvements to refer to a lower part contents, it wishes.

1) while eastern image remaking su khip operation of the back percentage case is occasionally and the problem amendment where the sound comes out with the phone substitution speaker

2) while MP3 remaking it is with a random one probability and the problem amendment where the sound comes out with the phone substitution speaker

3) while MP3 remaking with random one probability sound inside me problem amendment

4) from the MP3 regenerator MP3 music of Mono Channel in order not to droop, amendment

I understand :
- problem with mono MP3 fixed
- Probleme with headphone fixed
uh huh.......

Well then, shall I upgrade from 2.0 now? What are the remaining issues/concerns? Is everything better, or should I stay with 2.0?
it seems like i want the only one here that had the headphone bug (that the speakers stayed playing) but i had it only once. i'll update now.

After update, he ask himself if he may patch the gp2x, nice.
You can upgrade from 2.0 to 2.1.1 without any problems right? Like you don't have to go from 2.0 to 2.1 to 2.1.1..
Yay! Finally, the sound coming out of the speaker bug has been fixed. :)
I pretty much stopped listening to mp3s on the machine because of that bug.
I've been having a major issue with upgrading. I tried to upgrade to 2.1.0 and the green screen said my firmware was 2.0.0, but when I looked in the info menu, it said 2.1.0. It's doing the same thing with 2.1.1, and I can't change my startup sound.

How can I fix this? Today I tried downgrading to 2.0.0 but the Info menu still says my system is at 2.1.1, even though I did everything correctly.