Cant Get Usb Host To Work


Still Fresh
Aug 24, 2006

i've got a gp2x for a while now, and im quite addicted to gaming and developing on it :p

i tried to get the usb host on the EXT port to work, but im probably doing something wrong.

i made a cable from an e810 to a type A female usb cable.
becouse my gp2x provides 3.3v at the ext port, i only connected the ground, data+ and data- on the usb cable.
i checked if i had the correct ext pins connected to the correct usb pins for a couple a times, it seems ok.
there is a powered usb hub connected to the usb port, the hub certanly works and provides power.
when i plug in any usb device the gp2x just wont see it, keyboards mouses usb-harddisks memorysticks cardreaders, nothing seems to work.

i have usb host in the menu set to "always on", and storage and human interface are also turned on.

i even tried using firmware 2.0 instead of the 2.1.1 im using now.

just to be absolutely certain that my cable is ok, i checked for resistance between the data+ and ground wires, and the same for data-. wich gave me resistance.

with sterm i tried to mount sda, but it gives an error that the file doesnt exist.
there is no /dev/sda or anything that looks like sda, but there is a folder called "usb" with no contents.

what am i doing wrong?


it works! :D

after a lot of trying i found out that the EXT port/connector are acting strange when my gp2x boots.
when i push down (not to the inside) the modded e810 cable a bit when its connected till about 5 seconds after the menu, my memorystick starts blinking and everything works fine.
even when i stop pushing it downwords after that, and move the cable and EXT connector a bit, it keeps working... :blink:

i've build the USB filter from a schematic on the wiki here, but it didn't fixed the strange problem.
im now using it without the filter directly from the EXT port to the powered usb2.0 hub, and i think im goin to buy another e810 cable to see if that fixes the problem.

i've bought this cable (i just googled the picture...) from a webstore in the netherlands.

/dev/sda and /dev/sda1 turned up by itself when the hardware was found, but in the gp2x menu it didn't show any data when i went to the external storage menu.

i had to mount it manually with sterm with the command "mount -t vfat /dev/sda1 /mnt/ext" and then it all worked fine.

thnx for the help, can't wait to go wardriving with my gp2x :)