Best SD card sync method slot 1->2 on the Pandora


Advanced Member
Sep 7, 2010
I' ve been playing with my Pandora's a lot lately and want to have a solid and easy stand-alone back up strategy. I want to use my Pandora's only (so not with a PC) to back up and sync SD cards. The idea is to place the original card in slot 1 and transfer the files to slot 2 - and once every few weeks sync the back-up card.

Method for slackware (and maybe later try Letux-OS)

Start Pandora in SuperSaxxon (without SD cards) -> goto terminal -> rsync -avxHAX --progress /SLACK_1 /SLACK_2/
Works fine for Slackware (formatted EX2)
After that I want to keep both cards synced with -> rsync -avh --delete /SLACK_1 /SLACK_2/

Method for Pandora cards (with PND's)

Tried above for FAT32 Pandora cards and doesn't seem to work - files were not copied so tried
rsync -rv --progress /PANDA_1 /PANDA_2/

That worked but still not all files copied over. I was able to use PANDA_2 SD card though. I am wondering if the copy issues were the result of use of PND's. Once you place the SD card in the slot - the pandora will automatically scan for PND's. Not sure if the files are then 'in use' by the system and might result in write errors.

Other suggestions or comments welcome. Just looking for the easiest solution.


Still fresh, damnit!
Oct 6, 2008
Somewhere off the coast of the EU
rsync with -v or --progress should tell you everything that's going on. I don't have much experience with FAT formatted media myself, but I'd be surprised if that were an issue; you're only trying to read the file on the source drive, which should be permissible in any case. I don't know if slackware scans the pnds or not, but if locked files in an issue superzaxxon will definitely open files to read in /pandora/*.

But yeah, if it's not working right, look at your logs to figure out why.


Advanced Member
Sep 7, 2010
Thanks, I am on the right track then I guess. Will look for the log files next time to have a better understanding what happened.


Advanced Member
Sep 7, 2010
Used rsync -avh --delete /SLACK_1 /SLACK_2/ for Kingston cards formatted EXT2 and worked fine.

Kingston Canvas Select Plus 32 GB

rsync -rlt --delete /PANDA_F32/ PANDA_F32_1 |grep failed

Rsync -a should not be used for fat32 and -r is needed (fat32 doesn't have permissions). To identify the issue I've had I added |grep failed (so rsync will only show the errors)
Noticed some files with deviating characters that couldn't be copied. In the directory that had the incorrect files also FSCK files were present. These files are recovery files created by fsck
Removed the affected files and tried again and rsync didn't result in a failed message but checking the SD card with GParted resulted in a long check with new errors.

After syncing both cards have a different name that results in not working links (i.e. Pandafe) if you use the copy to disk. That is the only way you can sync it though so it is needed to change the name afterwards if you want to use a backup.

SD-card Toshiba M203/EA 64 GB

I've already had my doubts about the Toshiba cards that couldn't be used to install Slackware and this seems to confirm that (some of?) these cards are causing issues on the Pandora.

Method as described above seems to be a good method to make back-up cards and keep them synced.

Had a problem with one SD card and reformatting to EXT2 still didn't result in a SD card that would boot.
On my Linux PC:
sudo dd if=/dev/zero of=/dev/sdx bs=4096 count=4096 / this should zero out the first 16 MiB of the card and removed partition table.
With GParted
Added msdos partition table and formatted the card to EXT2 - including Linux - swap.

That didn't work / after copying image SD card still doesn't boot.

Tried the same with sudo dd if=/dev/zero of=/dev/sdx bs=4096 => GParted added msdos partition table - added 4 mb free space (I think DD will overwrite the partitions)

After that wrote the image

sudo dd if=~/slackware_backup.img of=/dev/sdx bs=4096 status=progress

Created image before with:

sudo dd if=/dev/sdx of=~/slackware_backup.img bs=1M status=progress

This method is a lot faster than the first sync on the pandora (after the first sync the update is done pretty fast - of course depending on the changes)

[edit] I am will update this post with my experiences and method updates.

[edit] april 11 2022 still using this method for back ups. The Toshiba card I primarily use on my main Pandora is still working fine (even with the errors that I had initially)

[edit] may 15 2022 noticed it is important to add '/' after the source SD card. If that is not added rsync adds a directory with name 'PANDA_F32 on the destination card and (in my case) sync will fail because of full disk error.
rsync -rlt --delete /media/PANDA_F32/ /media/PANDA_F32_1 |grep failed
Last edited: