Caanoo / WIZ Porting Gpfrontier To Wiz Problems


JoJo_ReloadeD

Still Fresh
Joined
Nov 18, 2007
Messages
19
Hi, I'm trying to port my gp2x port of Elite 2: Frontier to the Wiz and have several problems.

On gp2x I used open2x toolchain, and linked statically, altough I got this warning:
Code:
warning: Using 'getpwnam' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking

Anyway, the game ran flawlessly.

On Wiz, I used the only toolchain available for it, and couldn't get it working statically, I get a segfault.

I tried to link it with shared libs, and it worked! But after loading the 'Frontier' screen it failed with an internal error of the 68k emulation. No coredumps o warnings at linking time here.

Thinking it was from gcc version (this toolchain uses 4.2.4 and gp2x' used 4.1.1), I managed to build it with shared libs with gp2x toolchain.. but got same 68k error after the initial screen...

Any clues ? Thanks.
 

skeezix

Internal Development
Joined
Mar 11, 2003
Messages
8,064
Website
www.codejedi.com
(never looked into it)

Theres a lot of systems out there which carry 68k code around; ie: YM chipmusic players for the ST include a 68k emulator, since some chipmusic actually runs code. Likewise, the interpreter MAgnetic for Magnetic Scrolls IF text adventures includes a limited 68k emulator, since the story-files actually include 68k code (since they were originally for the ST and Amiga, but they actually backported them to the Commodore 64 and others.. 68k included!)

So it could just be that you need the 68k emulator for data in the game.

(Or maybe its just a ST/Amiga/Mac/X68000/whatever image with a CPU emu attached, as you say :)

jeff

As to the problem at hand.. time for piles of serial/printf/screen-logging/... so you can narrow in on exactly where it blows up, to get a clue. open2x toolchain should still work and is conservative about ARM-vaiation assumptions, so hmm... could be corrupted stack/etc that was masked in prior version, or random Wiz oddity you didn't expect.. need to narrow in :)
 

senquack

I feel a great disturbance in the source
Joined
Nov 1, 2006
Messages
1,167
Age
42
Location
USA
Website
Visit site
Pretty sure this is just a massive static recompilation 68k->C

Also, I read somewhere here that static linking on Wiz is not working yet (is this really true?)

On the archives there is a copy of gdb compiled for ARM that I sometimes use for debugging. It runs natively so you would have to have telnet access to the Wiz to get a backtrace.

There also of course is the remote debugging version of gdb (also on the archive somewhere) but that would require USB networking (is this working on the Wiz yet sheesh?)
 
Top