USB wifi in gingerbread pnd


Mar 20, 2004
England(north east)
Hi Guys ive just got my edimax wifi stick, works great in SZ1.51 speeds are from 400k -> 1.5mbs while I'm at work but I really got this stick for use with android. But I cant seem to get it to work. Do I have to super disable the onboard wifi or something.

when in android if I type iwconfig I see both wifi devices but it only connects with the first on wlan0 which is the onboard one.

Ive tried

ifconfig wlan0 down

ifconfig wlan1 up

which seems to kick off the wlan0 for a moment but it connects back up again quite quickly.

Any ideas how I can get rid of Wlan0 until I want it?



edit:how to : experimental not 100% sure if this is all thats needed yet. (I dont take blame for anything blah blah, but will try to help if needs be)

pretty simple trick I used to make my usb wifi work in android

  • make sure you have the usb stick plugged in and enabled.
  • open terminal
  • if you type iwconfig and hit enter you will see your 2 network connections.
  • enter sudo mousepad /etc/udev/rules.d/70-persistent-net.rules (you may want to back up this file just in case)
  • Hit Enter and enter password (I think pandoras come loaded with mousepad)
  • in this file you should have 2 lines which dont start with # these are the lines we are looking at.
  • scroll all the way to the right and you will see one has name="wlan0" and the other is names "wlan1" simply switch them over so the 1 is a 0 and 0 a 1. (you may want to back up this file just in case)
  • give a reboot
  • now if you do iwconfig you will see the numbers have switched, if you start up android now and connect to the wireless lan as normal open the terminal emulator and do iwconfig you will see its the new card connected at a higher rate (e.g my onboard said connected at 1mbps my usb says 150mbps)

good luck
Last edited by a moderator:
Last edited by a moderator:
np will keep my eye out for info on it you never know what you can do with this amazing box. dam 36 pages to read lol
Yey got it to work (Dances)

I tried a few things so not sure which of them or combination of which made it work

what I think was the kicker was changing the wifi stick from wlan1 to wlan0 and the onboard to wlan1 as I expect android just uses wlan0.

But I also rmmod wl1251 to get rid of the built in drivers.

now when I iwconfig from within android it shows onboard as wlan1 not connected and usb stick as wlan0 connected at 54mbps.

I wouldnt suggest anyone remove the onboard drivers though.

Ill try to do a bit of investigating tonight as to what doing this will effect. I know for a start that the toggle wifi button is hard coded to use wlan0 so that will now just disable the usb wifi and not the onboard.

Edit:Once im happy that I have found a way to do this without major repercussions . e.g still have onboard wifi working Ill post a guide.
Last edited by a moderator:
great job i used to hate android sooo dam much that is untill i could use it on my pandora
Hi Guys

as I has hoped and one of the reasons for buying i got onlive working sorry for terrible quality video stole girlfriends camera.

Ive had no side effects from changing the wlan0/1 around so far, so It should be pretty safe and worst case should be a switch them back. ill edit 1st post with what to do if some one wants to test.

edited 1st post with some info how to get this working

also this is using the xap from xda developers which says it works with all controllers. Wish I had a usb hub around to test with some bits.
Last edited by a moderator:
Sweet :) I wanted to test it to see if it's usable and bam "onlive is not available in your country"...damn...Belgium is not good for this kind of thing...
Awesome, can you post that guide? maybe on the wiki or (zLoud's tutorials site).

Also it would be good to let Notaz know that it can be done, and how, so he can update the main android sticky.