Relsoldered L button from L1 to L2.

Discussion in 'Support Area' started by Linux-SWAT, Aug 23, 2012.

  1. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,051
    Hi !


    I changed my L1 button, 'cause it was always on.


    Unfortunately, it's not related to the switch.


    So i resoldered the left L1 pin to the upper L2.


    My L button now activates L2.


    When i push L, i print the '+' character.


    1- How do i disable the still always pushed down L1 ? This is annoying when in pure console, 'cause shift is always on.


    2- How do i change the L2 from '+' to 'shift' ?
     
    Last edited by a moderator: Aug 23, 2012
    Tags:
  2. Askarus

    Askarus Hardcore Member

    Joined:
    Sep 28, 2011
    Messages:
    4,192
    Location:
    Germany
    That means if you change it you automatically change the +, too.


    Someone should define some Keycode for R2/L2.2
     
  3. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,051
    Yeah they're both the same now.


    I read on the manual it's the 97 gpio code, but i don't know how to use this information.
     
  4. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,051
    Some pictures:

    DSC05356.JPG

    DSC05357.JPG

    DSC05358.JPG

    DSC05359.JPG
     
  5. bukkit

    bukkit Member

    Joined:
    Mar 30, 2011
    Messages:
    208
    Keycode of left shoulderbutton ist 62 and mapped to Shift_R. Right one is 105, and usually mapped to Ctrl_R.


    The first one could probably be amended by doing



    Code:
    xmodmap -e 'remove shift = Shift_R'
    in a terminal. This should already be sufficient to mute the shoulder button, but for good measure you could add



    Code:
    xmodmap -e 'keycode 62 = '


    If that works, you put the two lines



    Code:
    remove shift = Shift_R
    
    keycode 62 = 
    
    
    in your ~/.pndXmodmap file (at the end).



    You could do the analogue with the 105. My reluctance to recommend that stems from the fact that the 105 doesn't seem to be specified in the ~/.pndXmodmap - and it is usually mapped to the Ctrl_R, but prints a plus in your case. You can try, analogue to the above,



    Code:
    remove control = Control_R
    
    keycode 105 = Shift_R NoSymbol Shift_R
    
    add shift = Shift_R
    
    
    ... but I'd take a look before. You could post the result of



    Code:
    xmodmap -pke | grep 105
    and have a look at "Start - Settings - Desktop - Keyboard", Tab "Application shortcuts" if this is messing with the button and remove those settings, if it does.


    (There are probably also layers of keyboard mapping unknown to me. I'd very much appreciate hints on those.)


    hth, bukkit
     
  6. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,051
    Well, i will try this, thanks.


    Anyway, i'm more looking for pure terminal advices, as it's where the trouble is really annoying.
     
  7. notaz

    notaz Certified Guru

    Joined:
    Aug 23, 2005
    Messages:
    4,908
    Location:
    Lithuania
  8. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,051
    Had to recompile a kernel anyway.


    Thanks.
     

Share This Page

Loading...