Mikmod changes?

Discussion in 'Support Area' started by Silent-Hunter, Aug 14, 2016.

  1. Silent-Hunter

    Silent-Hunter Hardcore Member

    Joined:
    May 29, 2010
    Messages:
    3,005
    I tried to use mikmod today, and the theme was mono, I always have it set to color. I tried that but it won't change. Also it only runs in xterm, trying to run it in the regular terminal makes it complain that it can't find xterm.
     
    Tags:
  2. FBnil

    FBnil Ready to Champion the Pyra to the World...

    Joined:
    Dec 14, 2012
    Messages:
    2,651
    Location:
    Yurp
    how did you get mikmod? (can't find it) and is it the player or the editor?
     
  3. Silent-Hunter

    Silent-Hunter Hardcore Member

    Joined:
    May 29, 2010
    Messages:
    3,005
    It's the player, I installed it with "opkg install mikmod" ages ago.
     
  4. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,181
    Is your OS up-to-date ?
     
  5. Silent-Hunter

    Silent-Hunter Hardcore Member

    Joined:
    May 29, 2010
    Messages:
    3,005
    Yeah, unless there's been another update in the past month or so.
     
  6. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,181
  7. FBnil

    FBnil Ready to Champion the Pyra to the World...

    Joined:
    Dec 14, 2012
    Messages:
    2,651
    Location:
    Yurp
    Mikmod howto.

    What is mikmod? Music module player. It plays *.mod, *.it *.s3m *.xm music modules.
    What are modules? Where can I get Modules? http://modarchive.org/?article-modules
    You can even play modules in your browser I like this song but this is my favorite masterpiece "Space Debris"
    Well, as you know, you can now safely drop to a shell, "sudo su" to root,
    "opkg update" and maybe an "opkg upgrade", but at least a "opkg install mikmod" (you can remove it afterwards with "opkg remove mikmod")

    Open a second terminal (or exit "root") and start mikmod by typing "mikmod".

    When you start mikmod however, it is low quality and really sounds bad, so lets change the initial settings.
    Press "c" and right to open the output options, then down to select HQmixer (press enter to toggle), enable surround, set reverb to 10.
    Not go back left, and down save the configuration, and use the configuration (press enter to activate these)
    Press "q" to exit, now start mikmod with the name of the mod as parameter. (or a directory).
    Press "h" for help.

    By the way, Markus redid his module in higher quality, here is the result:
     
  8. Silent-Hunter

    Silent-Hunter Hardcore Member

    Joined:
    May 29, 2010
    Messages:
    3,005
    Oddly, it randomly fixed itself at some point. It's been working for a while now.
     

Share This Page

Loading...