how enable a usb mouse ?

Discussion in 'General Discussions' started by Solstar, Dec 6, 2012.

  1. Solstar

    Solstar Member

    Joined:
    Feb 9, 2006
    Messages:
    293
    i tride to hook up a perfectly working usb small mouse for laptops on my pandora,it gets recognized,i turn on the usb host..but the mouse doesn't move,i still have to use the nubs and touch screen.the red light under the moues is on,so it is recognized but not.:"enabled",should i say.i went to sytem>mouse but the only avaialable options are,touch screen,nub 1 nub 2 and virtual core xtyest pointer...
     
    Tags:
  2. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    8,149
    Location:
    France, near Lyon
    USB Mouse are almost always USB1. So they don't work as is. You need to plug it thru a USB2.0 Hub.


    Also, once you plugged a USB1 in the Pandora, you crash the USB Stack and have to restart the Pandora.


    I use a Mouse, and it perfectly works, with a USB HUB.


    PS: Don't forget to active USB, it is deactivated by default to save power.
     
  3. FaeMinx

    FaeMinx Rainbow Liberation Instigation

    Joined:
    Dec 11, 2010
    Messages:
    3,093
    Location:
    outside looking in side looking out
    You need to use a USB 2 hub if you want to use a mouse.


    The Pandora doesn't support USB1 devices like most mice and keyboards.


    EDIT: :ph34r:


    Edit edit: There is no need to restart the Pandora, just disable usb host then re-enable. ;)
     
    Last edited by a moderator: Dec 6, 2012
  4. Solstar

    Solstar Member

    Joined:
    Feb 9, 2006
    Messages:
    293
    ah i see,luckily i had one collecting dust somewhere.it works ,but i have a question:before your reply i was looking at some older posts about the same issue,and some of you suggested to enable usb host -on at startup.well i clicked on startup in full desktop mode,asked from my password...and nothing happens...the mouse works fine but i still wanted the usb host command to be always on when i turn on the pandora.is there a command on the terminal to do so?


    edit:nevermind it works only on minimenu for some reason...
     
    Last edited by a moderator: Dec 6, 2012
  5. Linux-SWAT

    Linux-SWAT Hardcore Member

    Joined:
    Feb 13, 2010
    Messages:
    8,061
  6. TrashyMG

    TrashyMG Sarcasm Dispenser Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    10,251
    In the Settings menu of XFCE there is start-up options that can allow you to turn on USB host and other things on startup.. I'm heading to work right now otherwise I'd give you exact instructions.
     
    Last edited by a moderator: Dec 6, 2012

Share This Page

Loading...