Festplatte mounten unter Linux


JanWichmann

Newbie
Joined
Jul 13, 2007
Messages
339
Age
37
Location
Lübeck
LOCATION
Lübeck
Hi

Habe folgendes Problem bisher konnte mir keiner helfen aber ich denke mal das Gp2x Team kann ;)

Wie kann ich es einstellen das alle Festplatten/Partitionen beim Booten gemountet werden, habe es über die Fstab versucht. Aber jedesmal wenn ich den rechner neustarte macht er aus den eintrag auto wieder noauto. Als Os nutze ich Mepis müsste aber eigentlich von der Grundstruktur mit Kubuntu identisch sein. Hoffe ihr könnt mir helfen. Im moment muss ich mich immer erst als root anmelden die festplatten mounten. Mich abmelden und dann man ich mich als User anmelden.
 

double7

It's Evil Dragons magic
Joined
Nov 28, 2005
Messages
1,402
Du musst die auf Auto veränderte Zeile in den statischen Bereich der fstab (weiter oben) verschieben.

http://www.mepis.org/docs/en/index.php?title=Automount_drives
http://www.mepis.org/docs/en/index.php?title=Etc/fstab_won%27t_retain_edits
 

JanWichmann

Newbie
Joined
Jul 13, 2007
Messages
339
Age
37
Location
Lübeck
LOCATION
Lübeck
Hi

Habe das no for noauto weggenommen, nach den neustart ist es leider wieder da. Wie funktioniert das mit den Hochschieben.
So sieht meine Fstab im moment aus:


# Pluggable devices are handled by uDev, they are not in fstab
/dev/sda8 / ext3 defaults,noatime 1 1
/dev/sda7 swap swap sw,pri=1 0 0
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0622 0 0
# Dynamic entries below
/dev/sda1 /mnt/sda1 vfat noauto,users,gid=users,dmask=002,fmask=113,relatime 0 0
/dev/sda5 /mnt/sda5 vfat noauto,users,gid=users,dmask=002,fmask=113,relatime 0 0
/dev/sda6 /mnt/sda6 ext3 noauto,users,exec,relatime 0 0
/dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
/dev/sr0 /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
 

double7

It's Evil Dragons magic
Joined
Nov 28, 2005
Messages
1,402
Ausschneiden und einfügen, oder kopieren, löschen und Einfügen. ;)

Sollte hinterher so aussehen:
Code:
# Pluggable devices are handled by uDev, they are not in fstab
/dev/sda8 / ext3 defaults,noatime 1 1
/dev/sda7 swap swap sw,pri=1 0 0
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0622 0 0
/dev/sda1 /mnt/sda1 vfat auto,users,gid=users,dmask=002,fmask=113,relatime 0 0
/dev/sda5 /mnt/sda5 vfat auto,users,gid=users,dmask=002,fmask=113,relatime 0 0
/dev/sda6 /mnt/sda6 ext3 auto,users,exec,relatime 0 0
# Dynamic entries below
/dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
/dev/sr0 /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0

Oben ist der statische Teil, ab der zweiten Raute fangen die dynamischen Einträge an.
 

hede

Still Fresh
Joined
Oct 3, 2008
Messages
361
Das "users"-Flag, das normalen Nutzern das Mounten erlaubt, kannst du da auch raus löschen, denn hier mounted ja nur noch root. Wenn du nur einen und immer den selben aktiven Benutzer anmeldest, setz den Benutzer gleich per "uid="-Eintrag bzw. um auf Mehrbenutzersystemen jedem Schreibzugriff zu gewähren änder einfach das Masking, Beispiel:
Code:
/dev/sda1 /mnt/sda1 vfat auto,uid=jan,gid=users,umask=000,relatime 0 0

Wenn du es behalten möchtest, dass Dateien automatisch nicht ausführbar sind, setze anstelle "umask=000" eben "dmask=000,fmask=111".

Genauere Infos verrät dir "man mount" und "man umask".
 

JanWichmann

Newbie
Joined
Jul 13, 2007
Messages
339
Age
37
Location
Lübeck
LOCATION
Lübeck
Danke ihr seit echt die besten werde es am Wochenende ausprobieren bin in moment auf montage.

-- So Nov 14, 2010 14:14 --

Ein riesen Dankeschön an double7 und hede für die schnelle Lösung meines Problems der PC läuft jetzt wieder wie er soll!!!!
 
Top