Release Easy RPG Alpha PND for Pandora

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,482
Age
47
Location
France, near Lyon
Pushed the 0.4.1 version to the repo (with a slightly simplified version of fluidsynth, without IIR filter, to have better speed).

Build 05
------------

  • Using 0.4.1 sources
  • Removed IIR filter from fluidsynth
 
Last edited:

ingoreis

Advanced Member
Staff member
Joined
Jan 18, 2010
Messages
8,089
Age
38
Location
49.491276,8.423518
@ptitSeb
Hi a little Error Report:
The Gaming Buttons do not work more.
Maybe here is a good Time to say the Whish that Gaming this RPG Games
should be much better with the X and B Buttons :D

The older Combo with A + B Button is not perfectly for me :)

The little Speedboost ist very feelable with the lowered Fluidsynth.
Congratz for this new Version and Thank you again :happy:
 
Last edited:

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,482
Age
47
Location
France, near Lyon
@ingoreis : about the keys, my patch didn't applied (I didn't saw the reject), before fixing it, it seems you want some changes?

Currently, I have assigned {X} to DECISION, {A} to CANCEL and {B} to SHIFT (that's the name of the buttons in code). Plus, if ".flipbx" is present in the appdata folder, {X} and {B} are flipped.

How would you like the next version to behave (what Pandora buttons to what Game buttons should I assign)?
 

ingoreis

Advanced Member
Staff member
Joined
Jan 18, 2010
Messages
8,089
Age
38
Location
49.491276,8.423518
@ptitSeb
Oh thx for asking :)

My Recommend is simply
{A} to CANCEL changing to {Y} Button because this Button do very often open a Menu in the Classic RPGMaker Games
and the Button is more Easy to reach then for me too :$

no more Whishes ;)
 
Last edited:

JePP

Member
Joined
Aug 29, 2005
Messages
366
Location
Germany
Thank you so much for this port!! RPG Maker games were a big part of my childhood! And the new version works surprisingly well! With this software, an enormous amount of awesome RPGs are at our fingertips and I am genuinely stunned at just how little attention this wonderful tool seems to get in the internet.

One question which I haven't managed to solve though:

How do we install the RTP? The only instruction I could find was here: https://easy-rpg.org/wiki/user/player/rtp but /pandora/appdata/easyrpgplayer/data/rtp/2000 does not seem to work! And neither does exchanging the folder name "easyrpgplayer" with "easyrpg" seem to work. Thus, the player always says that RTP could not be found. What is the solution here? And could you also add this information to the repo entry? Thanks!!

PS: I advise anyone to play Vampires Dawn: http://rpgmaker.net/games/4626/ <- English version! One of the best RPGs out there (not sure if there's also a translation of the second part)!

PSS: http://www.multimediaxis.de/threads/125604-RPG-Maker-Spiele-DOWNLOAD-Neu-Dropbox-Datenbank-im-Aufbau -> BIG cache of games listed, for example: https://www.dropbox.com/sh/ebf4ck9wu9ax177/oGVn4n3BPR
 
Last edited:

Ghabry

Still Fresh
Joined
Feb 9, 2015
Messages
23
/data really means in the /-root ... This is for embedded systems.

You can use environment variables instead as mentioned in the wiki:
RPG2K_RTP_PATH: For the RPG2000 RTP
RPG2K3_RTP_PATH: For the RPG2003 RTP

In my opinion Vampires Dawn is not a good game (anymore). It didn't age well. Everybody only loves this because it is his childhood ^^. VD is just a grind fest. Unterwegs in Düsterburg is of the same age and muuuch better.
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,482
Age
47
Location
France, near Lyon
May be I should create a rpg2k and rpg2k3 folder in appdata/easyrpgplay and point those 2 variable to it, to make things easier?
 

JePP

Member
Joined
Aug 29, 2005
Messages
366
Location
Germany
/data really means in the /-root ... This is for embedded systems.

You can use environment variables instead as mentioned in the wiki:
RPG2K_RTP_PATH: For the RPG2000 RTP
RPG2K3_RTP_PATH: For the RPG2003 RTP

In my opinion Vampires Dawn is not a good game (anymore). It didn't age well. Everybody only loves this because it is his childhood ^^. VD is just a grind fest. Unterwegs in Düsterburg is of the same age and muuuch better.
How do I use these variables on my Pandora?
I never played UiD, will have to try it :) Is there experience yet of how well it performs in EasyRPG? Is it finishable? Which reminds me.. Is there a wiki somewhere that indicate how well games are supported?

May be I should create a rpg2k and rpg2k3 folder in appdata/easyrpgplay and point those 2 variable to it, to make things easier?
That would definitely make things a lot easier :)
 

JePP

Member
Joined
Aug 29, 2005
Messages
366
Location
Germany
For most of the games I believe RTPs are needed. I downloaded the RTP 2000 1.32 version and the 2003 RTP (both can be found with Google), hope they will work once they are linked correctly!
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,482
Age
47
Location
France, near Lyon
Ok, on the repo is an updated pnd, featuring a slightly updated build and some helpers for the rtp packages. Launch it 1 time and 2 new folder will be created appdata/easyrpgplayer/rtp2k and appdata/easyrpgplayer/rtp2k3
Put the rtp files inside and they should be used automatically now (I haven't tested).

Build 07
------------

  • Updated sources
  • Put rtp2000 files inside appdata/easyprgplayer/rtp2k if you have the package
  • Put rtp2003 files inside appdata/easyprgplayer/rtp2k3 if you have the package
 

Ghabry

Still Fresh
Joined
Feb 9, 2015
Messages
23
Is there experience yet of how well it performs in EasyRPG? Is it finishable? Which reminds me.. Is there a wiki somewhere that indicate how well games are supported?
Well we have a Wiki but the game list is basicly almost empty and useless because you never get user reports when a game was finished successful.

Our main source of information is a bug report system integrated in the Android port. The last big "main story" blocker bug in UiD we are aware of (and is fixed) is already months ago and was really far in the game (~75%). So it should be enjoyable :).

And we don't give official support for the Pandora version. But it should run as good as the other versions.
 

JePP

Member
Joined
Aug 29, 2005
Messages
366
Location
Germany
Ok, on the repo is an updated pnd, featuring a slightly updated build and some helpers for the rtp packages. Launch it 1 time and 2 new folder will be created appdata/easyrpgplayer/rtp2k and appdata/easyrpgplayer/rtp2k3
Put the rtp files inside and they should be used automatically now (I haven't tested).

Build 07
------------

  • Updated sources
  • Put rtp2000 files inside appdata/easyprgplayer/rtp2k if you have the package
  • Put rtp2003 files inside appdata/easyprgplayer/rtp2k3 if you have the package
Thanks! It works great. For everybody else confused about the RTPs, they are often not put on webpages because of copyright issues, but can still be found with Google. Look out for RTPe.zip which is the Rtp2k, also download RTP 2000 1.32 which are additional files that some games might use (add these files within the Rtp2k folder!) + RTP2k3. Feel free to message me for more help. Also, one thing I noticed, is that while copying game files from a Windows system to the SD card, it may override Umlaute (ö ä ü ß) with unknown characters, leading to the game not being able to locate the files. I now renamed these files right on my pandora, for example HauptmenX.png to Hauptmenü.png etc., then it works.

@Ghabry thanks for the info! Its too bad about the compatibility list. Maybe more people would contribute to it if it would be easily accessible through the main site https://easy-rpg.org/ , e.g. besides "Blog" etc. "Compatbility List". Right now, it seems quite hidden for the average user, so perhapy increased visibility might result in more contribution.

One last thing: Even on max brightness, EasyRPG can be quite dark, for example in Dreamland R I end up having to tilt my pandora sometimes to see more clearly what's going on. Would it be possible to increase brightness further somehow?
 

Ghabry

Still Fresh
Joined
Feb 9, 2015
Messages
23
@Ghabry thanks for the info! Its too bad about the compatibility list. Maybe more people would contribute to it if it would be easily accessible through the main site https://easy-rpg.org/ , e.g. besides "Blog" etc. "Compatbility List". Right now, it seems quite hidden for the average user, so perhapy increased visibility might result in more contribution.
I don't think this will really help because we don't have many visitors. We don't collect statistics but the amount of visitors is low. Our biggest thing is probably the Android version, but they don't know/care that we also have support for other platforms.

One last thing: Even on max brightness, EasyRPG can be quite dark, for example in Dreamland R I end up having to tilt my pandora sometimes to see more clearly what's going on. Would it be possible to increase brightness further somehow?
We simulate the RPG_RT behaviour, must be a design flaw in the game.
 

Ghabry

Still Fresh
Joined
Feb 9, 2015
Messages
23
Information for maintainer: We got some changes to the audio system over the last weeks which fixes lots of audio issues in EasyRPG (bugs in SDL2 (noisy audio and crashes) and lack of features like speed adjustments). There is no official announcement or documentation for this yet because the new version isn't out yet.

The new optional, recommened dependencies are:
libsndfile (WAV playback)
mpg123 (MP3 playback)
tremor or ogg (OGG playback)
speexdsp (Resampling, pitch changes (adjusting playback speed is a RPG Maker feature))

Using our audio stuff without speexdsp makes no sense, speed will be wrong.

These setting are auto-optin when "configure" detects them.

Optional, additional settings, you can ignore them, off by default:
--enable-fmmidi=yes - Uses FM Midi (built-in, no external deps) for Midi playback instead of SDL. Resource heavy (doesn't matter when system is dual core), sounds different.
--with_libwildmidi=yes - Uses libwildmidi for Midi playback. Uses the same config file as timidity.

The default behaviour is: Midi falls back to our built-in FMMidi when SDL fails to play it (e.g. Timidity config file missing)

Fluidsynth and timidity will probably come very soon, too.

Also take a look at "configure --help" ;)
 
Last edited:
Top