Audio Out


zedr0k

Member
Joined
Oct 28, 2015
Messages
44
Location
Germany
ICQ
62214606
Hi, I tested the headphone output for the first time today. And it doesn't work. Do I have to activate the output first, or should the pyra switch it on automatically when the plug is inserted?
 

matzesu

Forum Addict!
Staff member
Joined
Oct 24, 2008
Messages
11,191
Age
37
Location
Germany,, Saarland, at home
You have to activate it first, the switch isn’t implemented yet , but you just have to use the Audio Control menu you get when you click on the audio symbol in the task bar
I would recommend Bluetooth headphones, as I got some noise on my Kabel headphones..
 

zedr0k

Member
Joined
Oct 28, 2015
Messages
44
Location
Germany
ICQ
62214606
Hi Matze, thanks for your answer. I already looked there. But the only output-device available is "built-in-audio"; nothing else there to activate.
 

matzesu

Forum Addict!
Staff member
Joined
Oct 24, 2008
Messages
11,191
Age
37
Location
Germany,, Saarland, at home
Ok then it should work, I can remember that I once used a normal cable headphone, and it’s ditnt came trough the speakers...
but I can look on this yet, give me a few moments
 

pyrat

Very Active Member
Joined
May 20, 2016
Messages
621
I don't have a Pyra yet, so I don't know, but until you get some best answer... Have you tried pavucontrol and alsamixer ?
In alsamixer sometimes you have to change sound card (with F6) , and turn volumes (cursor keys) up or unmute (M key) . I don't know.
 

matzesu

Forum Addict!
Staff member
Joined
Oct 24, 2008
Messages
11,191
Age
37
Location
Germany,, Saarland, at home
Ok i just dit a quick Test; whiteout Headphone, Audio over speakers, whit headphones, audio over headphones
Dit you allready update your Debian?
( sudo apt update, then your password when it’s ask , then sudo apt upgrade)

Also; in headphones Mode, the wheel dosnt Controlls the loudness, you have to click on the controls in the task bar
 

zedr0k

Member
Joined
Oct 28, 2015
Messages
44
Location
Germany
ICQ
62214606
Thank you Matze for testing.
Yes, debian is up-to-date. I already tried alsamixer, But I can't activate the headphones. I will try booting a fresh system from sd-card to check, if it is a software or hardware issue.
 

matzesu

Forum Addict!
Staff member
Joined
Oct 24, 2008
Messages
11,191
Age
37
Location
Germany,, Saarland, at home
Could be my System isn’t that original, as I also installed jack, and screwed around whit Alsa 2 weeks ago, and I can’t remember when my first try was ^^
So I don’t know if it’s comparable to other Pyrae ..
 

zedr0k

Member
Joined
Oct 28, 2015
Messages
44
Location
Germany
ICQ
62214606
found out. It works fine with mate, but it doesn't work with xfce. So maybe some drivers aren't loaded in xfce

...thanks to both of you guys :)
 

matzesu

Forum Addict!
Staff member
Joined
Oct 24, 2008
Messages
11,191
Age
37
Location
Germany,, Saarland, at home
The question I ask me: how much independence is ok on this state of the development?
Xfce instead of mate means you can’t compare to find the issue,
Then some got jack installed or something..
and this is just the Debian on the OMAP 5
What might happen when whe have a new CPU Boards, which needs its own ported OS,
Or if someone uses letux instead of Debian
Nobody will look through anymore
(Da blickt doch keiner mehr durch)
 

pyrat

Very Active Member
Joined
May 20, 2016
Messages
621
I wouldn't worry too much. Diversity is good. The Pyra will still come with some distro/desktop/system preinstalled and most people will use that. Community support will probably focus on that, but since "that" is an open system, those interested in alternatives can always look how something was solved in "that" and then apply the knowledge in "this". Yes, it requires some learning sometimes, as long as you step out of the factory image, but it also enables more learning than any other way, so it works. @matzesu, if you ever find difficulty in things you try, remember that very few of us have Pyras yet, and so we often hesitate to help because we can't try what we suggest and we might lead you astray. With time and Pyras, chances are that when you ask someone doesn't even have to try because they have already done that on their Pyra, so they know and can just tell you, just as you tell others now. Don't worry, software is soft.
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,781
Age
43
Location
Ingolstadt
Once the drivers are properly working, it shouldn't be an issue anymore anyways, similar to a normal PC.
But we have some workarounds for the weird audio setup at the moment, that could cause issues.
 

zedr0k

Member
Joined
Oct 28, 2015
Messages
44
Location
Germany
ICQ
62214606
You might need Pulseaudio as it routes the channels properly.
Maybe XFCE doesn't support that properly?

yes pulseaudio is installed and works perfectly with mate. maybe something is missing or not loaded under xfce. I'm just switching to mate for the moment.

I'm just glad that the mistake sat in front of the pyra and wasn't the pyra itself. So it is more easy to fix. ;)
 

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
14,336
Location
Somewhere off the coast of the EU
I think the most pertinent question is; how did you install xfce? Did you start from the pyra image with mate and uninstall mate and install xfce? Or did you start from some more basic debian command line and installed xfce from there? If the former you should have uninstalled a package that handles headphone plugging and unplugging, and we may be able to identify it. If the latter it's a little more complicated, and you'd need to look at the dependencies of mate all the way down, and compare that against the packages you did have installed when using xfce. I assume mate isn't coming from the pyra repos, indicating it may well have been patched itself, rather than coming from debian and being the same codebase that's running on rpi and others. Of course an rpi doesn't have to cope with headphone removal events, since it doesn't have onboard speakers, so if you want any sound out it has to go over headphones or maybe the HDMI channel.
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,891
You might need Pulseaudio as it routes the channels properly.
Maybe XFCE doesn't support that properly?
There's usually an Xfce user space daemon which can be enabled in the Xfce menu -> parameters -> session and startup.
Dunno what its purpose is but I think it's enabled by default in a Slackware install.
 
Last edited:

zedr0k

Member
Joined
Oct 28, 2015
Messages
44
Location
Germany
ICQ
62214606
I think the most pertinent question is; how did you install xfce? Did you start from the pyra image with mate and uninstall mate and install xfce? Or did you start from some more basic debian command line and installed xfce from there? If the former you should have uninstalled a package that handles headphone plugging and unplugging, and we may be able to identify it. If the latter it's a little more complicated, and you'd need to look at the dependencies of mate all the way down, and compare that against the packages you did have installed when using xfce. I assume mate isn't coming from the pyra repos, indicating it may well have been patched itself, rather than coming from debian and being the same codebase that's running on rpi and others. Of course an rpi doesn't have to cope with headphone removal events, since it doesn't have onboard speakers, so if you want any sound out it has to go over headphones or maybe the HDMI channel.

I came from standard pyra-image and installed xfce from the debian repo. I've never used audio out before so I only noticed it now. But it works with mate. And I get along well with mate too. So, it's okay for now.
 

elvissteinjr

Very Active Member
Joined
Jun 19, 2010
Messages
757
Age
25
Location
Germany
If the former you should have uninstalled a package that handles headphone plugging and unplugging, and we may be able to identify it.
There is something like that on the Pyra? It's not like the speakers stop outputting anything when plugging in headphones so I just assumed that output is also always driven (save for manually muting either of course).
 
Top